After turning on the xdebug listener in phpstorm - all requests becomes paused.

Answered

After updating ubuntu, the request began to hang when the listener is enabled in the phpstorm xdebug. How can I fix this?
All settings are normal. I went through https://xdebug.org/wizard.php. phpize matched. I decided to reinstall it. My phpize with pkhp 7.3 coincided with wizard. In phpinfo xdebug is displayed. In php -v also. Even more, in phpstorm it catches the connection. The problem is that when I send a request to the server, with the listener turned on, my request does not reach the breakpoint, the request just hangs and nothing happens. What could be the problem ? Who knows ? In general, I have no idea what could be the problem. I really need your help, help who knows what the trouble may be.

1)I went through all the hints from https://xdebug.org/wizard.php 
2)In phpinfo everything is ok.
3)Everything seems to be fine in the phpstorm settings too. I did not change them, I always worked with those who stand now.
4)After I turn off the listener, the request immediately passes. 
5)After sending the request, the stop button near the listener does not light up. 
6)I turned on "Break at first line in PHP scripts"
After that I caught the first line of my application with debager. But when I pressed F 8, the debager did not reach my ripping point, but hung up as before. In an endless pause.
7)If you put the maximum connections in the settings of xdebug phpstorm for example 5-7, then the debager will stop in the first line of the application, but then when you press F 8, then in the debager panel it will say "Connected"
8)
netstat -a -n | grep 9000
tcp 0 0 0.0.0.0:9000 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:53658 127.0.0.1:9000 ESTABLISHED


My php.ini [xdebug]
xdebug.default_enable = On;
xdebug.var_display_max_depth = 6;
xdebug.remote_enable = On;
xdebug.remote_host = 127.0.0.1;
xdebug.remote_port = 9000;
xdebug.remote_handler = dbgp;
xdebug.idekey = phpstorm;
xdebug.remote_autostart = 1;
xdebug.profiler_enable_trigger = 1;
xdebug.profiler_enable = 0;
xdebug.profiler_output_dir = /tmp/xdebug/profiler/;
xdebug.show_local_vars = 1;
xdebug.overload_var_dump = 1

6 comments
Comment actions Permalink

if press F8 

1
Comment actions Permalink

As you did not change anything in PhpStorm installation, I was wondering what exactly has been updated in terms of Ubuntu — an overall installation (to the different version) or just some updates installed?

I just tried to install the latest updates on my Ubuntu 18.04.2 VM and it seems to be that debugging is working as before.

 

0
Comment actions Permalink

I just updated, did not update 2 months and then auto-update of everything appeared and I decided to update. About what I regretted 100 times. I have Ubuntu 16.

0
Comment actions Permalink

I tried to make a debug through the console. In general, there is a slightly different picture, other requests have passed, and that's where the breakpoint was, as I understand it, the request stopped.

0
Comment actions Permalink

update phpstorm solved this problem

0
Comment actions Permalink

Thanks for sharing! I assume that you have installed PhpStorm 2019.1. Out of curiosity, what version did you have before?

0

Please sign in to leave a comment.