How to fully disable Live Edit?

Currently I am working on angular app. Because Live Edit doesn't suit my needs I need to disable it somehow. Tried to disable it in WebStorm settings but it's still working. When working on this app in VS Code there wasn't Live Edit working so it means it's not fault of plugins built in app files. Maybe some good soul here will help me?:)

6 comments

Disabling all options in Settings | Build, Execution, Deployment | Debugger | Live Edit should be enough.

Why do you think it's not disabled?

0

I already disabled it in plugins section so now I don't even have it in debugger options. But anyway it's still working with angular

0

I think so because when I change something in any html or css file the page is reloaded

0

do you save your changes explcicitly by hitting Ctrl+s or changing focus to/from the IDE?

0

The page is reloaded automatically when I change focus from IDE to Chrome

0

It's expected - files are auto-saved on frame deactivation (this is controlled by Save files on frame deactivation option, Settings | Appearance & Behavior | System Settings). And file saving triggers Angular cli live reload.

You can run ng serve with the --liveReload=false option to not reload the browser on change or use --poll to increase the timespan between the change detections.

Refer to the official documentation for the options.

1

Please sign in to leave a comment.