React plugin stopped working after update

Title says it all. I do not get the same feedback as previously.

When I updated Intellij, the entire software hung up and I had to shut it down through task manager. Didn't work so I restarted my computer entirely. Next thing it does is to ask whether it should switch to JSX which I pressed Switch a million times yet it did not do anything.

I use the standard colour and font theme.

I have attached a screenshot of one of my constructors.

Please help!

Thanks

11 comments

Looks as if advanced syntax highlighting is disabled for your file. Do you have Power Save Mode (File | Power Save Mode) enabled? Also, click the Hector icon in lower right corner - what highlighting level is chosen there?

0

Power Save Mode is not enabled and the highlighting level is set to inspections.

I tried entering another project and it seems to work so my guess is that something project specific has happened.

0

Did you try deleting the .idea folder and re-creating the project from scratch?

0

I did and now the Switch language version to React JSX showed up however it just remains there even if I press Switch

0

what does your project look like? Do you have a single web module, or several modules? Can you share a project the issue can be recreated with?

0

I have one web module inside my Java application. the folder webapp contains all of my React related things.

Everything worked until I updated node in IntelliJ. I do not know what the update changed though.

0

Sample project with similar structure would be helpful...

0

https://github.com/shayanfalla/demo 

I created a quick project and uploaded it to github.

0

works for me using your demo project:(

 

can you share your settings (File > Export settings) and idea.log?

0

Hi, sorry for the delay.

I cannot find the Export Settings option in File. What am I missing?

Also, where can I find the idea.log? :)

0

>I cannot find the Export Settings option in File. What am I missing?

 

This option is not available when you have Settings Sync enabled.

There is an open issue, IDEA-202548, please check comments there.

 

>Also, where can I find the idea.log? :)

 

Please try Help | Show log in <your file manager>

0

Please sign in to leave a comment.