"Fix ESLint Issues" Does Not Work

When right clicking and selecting 'Fix ESLint Issues', the loading bar for fixing ESLint issues blips for a split second, then disappears without fixing anything. If I run the command manually through Power Shell, `./node_modules/bin/eslint --fix testFile.ts` it works properly without issue.

 

ESLint in my project is configured to use the local script within the project, and I have manually set it to use my `.eslintrc.js` file for testing.

 

Has anyone else had experiences/issues like this? Is there any way to see the log of what's happening? I dug around for a bit but was unable to find anything for ESLint.

 

I have tried invalidating my indexes/caches and restarting IntelliJ. Additionally I don't get any ESLint errors for things that `eslint --fix` fixes.

 

IntelliJ Idea Version: 2018.3.5

.eslintrc.js: https://pastebin.com/hi8pUjrZ

package.json: https://pastebin.com/Rax4NV4P

 

I simplified my .eslintrc.js, but I still get the same result. https://pastebin.com/u2tArn5h

13 comments
Comment actions Permalink

can't recreate using your setup... Is the issue specific to certain file(s)?

But the strange thing I've noticed is that running eslint --fix src/App.tsx
in terminal results in changing file formatting over and over again, with a different number of errors (fixable and non-fixable) reported on each run.

0
Comment actions Permalink

Elena, I ran into that issue when testing with VSCode. The fix was to remove airbnb since it's fighting everything around it. Updated eslintrc pastebin.

For some reason VSCode doesn't seem to have an issue. Is there any way I could find a log of what it's failing at or get a more verbose output?

0
Comment actions Permalink

please enable debug logging for #com.intellij.lang.javascript.service.JSLanguageServiceQueue:trace ( Help | Debug log settings), recreate the issue and provide the idea.log.* files (https://intellij-support.jetbrains.com/hc/en-usa/articles/207241085-Locating-IDE-log-files)

0
Comment actions Permalink

there are no traces related to ESLint fix in the logs...

Please, can you check if the issue persists in 2019.1? ESlint integration has been changed significantly there.

0
Comment actions Permalink

Just updated to 2019.1, It looks like the issue is still present.

0
Comment actions Permalink

I just tried deleting all config files for IntelliJ as well as the project but this didn't fix it either.

0
Comment actions Permalink

Please try getting new logs in 2019.1 (with #com.intellij.lang.javascript.service.JSLanguageServiceQueue:trace enabled): enable logging, restart the IDE, reproduce the issue and provide the log files

0
Comment actions Permalink

Removing `'plugin:@typescript-eslint/recommended',` from .eslintrc.js seems to make ESLint work again in IntelliJ.

0
Comment actions Permalink

From the log I can see some issue fixing the code that are caused by parsing errors, like:

"message":"Parsing error: Property or signature expected.","line":83,"column":14

that occurs in crm-app/src/types.ts

But eslint --fix i terminal will fail for this file as well because of this error...

0
Comment actions Permalink

What's really odd, I put the typescript-eslint line back in, and it appears to be working now. I'll keep you posted if I see any additional weirdness. I'm wondering if something about that file was throwing errors between the ESLint plugins that IntelliJ didn't like. 

0
Comment actions Permalink
So, I'm having the same issue with a similar setup.  I was able to get it to log eslint stuff, but it truncates it!  How can I get the full output? 

2022-04-22 14:34:51,643 [ 299957]   FINE - #c.i.l.j.s.JSLanguageServiceQueue - Protocol Request: {"sessionId":1650663007319,"seq":24,"type":"request","command":"GetErrors","arguments":{"fileKind":"js_and_other","fileName":"/home/forrest/code/whatever/.eslintrc.js","configPath":"/home/forr
 ................................(truncated)
0

Please sign in to leave a comment.