Cannot type brackets or braces in Pycharm

Canadian Multilingual Standard keyboard layout.

Whenever I press AltGr+7 or Ctrl+Alt+7, nothing happens in the editor. I get an opening brace if I do it in another program. The same thing is happening for the closing brace and brackets.

I figured I had conflicting keymaps, but I checked and there is nothing configured for Ctrl+Alt+7, Ctrl+7 and Alt+7.

I am pretty confused about why it won't work.

25 comments

Same in Spanish keyboard.. but in CLion 2019.1 works ¿¿??

3

Just installed PyCharm 2019.1 Comm Edition and have the same problem with German keyboard.

Not possible to insert any character requiring the Alt-Gr key, e.g. curly braces and square brackets which are essential for programming.

 

3

Same for me with German Keyboard.

4

Same problem with Scandinavian keyboard

2

Same for me with french keyboard

1

Same problem with Swiss-German keyboard, cannot write [, ], {, }

2

Same trouble with belgian keyboard and all AltGr combinations on PyCharm 2019.1

0

This is a BUG and a critical one from user perspective

5

I followed some age ole instruction in this ticket: https://youtrack.jetbrains.com/issue/IDEA-88508

Adding "actionSystem.force.alt.gr=true" to the bottom of the ...\bin\idea.properties file "solved" the issue for me.

5

@Matthias Manhertz: Thank you, that worked in my case! Would still like to see the bug fixed though.

0

Same problem. The fix worked though ty !

ps: FR keyboard

1

Worked for me using SWE keyboard. Not being able to enter { or [ is rather fundamental when coding in Python.

PS! The 2019.1 version was installed over the 2018.3.4 folder in my case so I uninstall 2018.3.4 by first install 2019.1, then copy Uninstall.exe from the 2019.1 bin folder to the 2018.3.4 folder, uninstalled 2019.1 (just in case), rebooted and installed again. Plus the actionSystem.force.alt.gr=true fix and now it's working.

0

Same here.

German keyboard, Ideavim.

Workaround solved.

ty

0

Same problem here, Swiss German keyboard. After installing pyCharm 2019.1Could not type any brackets and even the dash: {}[]#... quite annoying.

The workaround `actionSystem.force.alt.gr=true` in the `idea.properties` file solved it, but I was expecting an update to solve this.

If Jetbrains is flooded with support requests about this issue maybe they will release an update I guess... else thx google for being my friend and making me find this post. Thanks @Matthias for sharing the fix.

0

PyCharm greeted me with this today:


PyCharm 2019.1.1 is now available.
AltGr fix (for real this time)

So I guess this is settled?

-3

Not working with  Belgium period keyboard on Win 10 1809.

Adding "actionSystem.force.alt.gr=true" to the bottom of the ...\bin\idea.properties file "solved" the issue 

Double checked that this addition is needed to get AltGr active.

0

I had a same issue with Finish keyboard. I fixed that issue by going to Help and then Edit Custom Properties. It will immediately open a file where u need to put this: actionSystem.force.alt.gr=true  , then just save it. I needed to save it with a new name. Then close pycharm and restart.

1

I am having the same issue with a Spanish keyboard (Windows 10)

0

Everyone who is affected, please try the following workaround: https://youtrack.jetbrains.com/issue/PY-34816#focus=streamItem-27-3366765.0-0

It also explains the root cause and when the issue will be resolved

0

Same thing. Working with PyCharm 2019.1.2 downloaded today may9  and I can´t write left braces [ { with the spanish keyboard on Mac. Can do it on the english keyboard but that is a problem. Tried to change  actionSystem.force.alt.gr but it was already false (with ALT CMND SHIFT SLASH and then Registry). I am evaluating PyCharm for my company and this thing is a no-go.

0

Hi Dmitri, I am sorry for the inconvenience, we are investigating the problem with Spanish layout. Please follow the dedicated ticket for updates https://youtrack.jetbrains.com/issue/JBR-1421

0

For spanish keyboard the only solution for the moment is

Help->Edit custom properties

add

com.jetbrains.use.old.keyevent.processing=true

9

Works perfectly, thanks @Gatacapone!!!

0

Also works for me with Spanish keyboard. Thanks @Gatacapone!

0

Please sign in to leave a comment.