Flutter/Dart Auto-Suggestion and Emulator menu not working with 2019 update

Answered

Hi,

I'm using Intellij for two months for developing Flutter applications, after the 2019 update, I was able to use Intellij for 1-2 hours but suddenly, I don't know why I couldn't use auto-suggestion features, also emulator menu up above have disappeared. I didn't change any settings. What should I do?

4 comments

Hello Esen,

Have you tried to run "File | Invalidate Caches/Restart"? If it doesn't help please report issue on YouTrack attaching logs folder zipped (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files): http://youtrack.jetbrains.com/issues/IDEA.

 

1

I tried the invalidate/restart already but not worked, ok, I'm sending my log file as like as you said.

Thank you for your help.

0

I am having the same issue.  But I have an emulator menu, and my intellisense works "inside" widgets

For example...  When I start to write "text" on the line that says "return text"   Flutter use to auto complete and would popup a intellisense Menu showing "Text()" as a option.   now nothing shows up except methods and functions in my file, no Widgets from flutter.   (the intellisense works "inside" flutter widgets still, just not the initial auto complete of the widget itself) so inside Text(   I get intellisense like "textAlign" etc... but how do i get the parent intellisense back?   it recognizes my project is a flutter project.. it recognizes the LIB directory as the project sources and it also has the Flutter ICON in the project root by my folder name, etc.. its definitely a flutter project.  Also my Highlight level is at inspections and power save is OFF.

Some info:

Mac Laptop - IntelliJ Ultimate 2019.1  - not working.

PC Desktop - IntelliJ Ultimate 2018.3.6 - working.

these are projects from a GIT repo so i can open the same project and one is ok one isn't.   I tried to check various things like project settings and framework SDK and plugins but nothing is making it work for me.

class whatever extends StatelessWidget {
@override
Widget build(BuildContext context) {
return Text <----- THAT SHOULD POP INTELISENSE and show "Text()" as a widget in Flutter. (Along with any other widget like Container() etc
}
}
1

Please sign in to leave a comment.