can't pip install qiskit

In the terminal mode in Pycharm

Try to:
pip install qiskit

I got:
"Collecting qiskit
Could not find a version that satisfies the requirement qiskit-aer==0.1.1 (from qiskit) (from versions: 0.1.0)
No matching distribution found for qiskit-aer==0.1.1 (from qiskit)"

I am using:

  • Qiskit version: latest version
  • Python version: 3.7
  • Operating system: windows 10

This may not strictly PyCharm related, as I also run it at cmd, and I got the same error.

I also posted this on Github.

4 comments
Comment actions Permalink

Had the same error, but did not find a solution online (all mentioned that I need 3.5 or above version of Python).

One solution is building Aer 0.1.1 from source and then installing QIS.

Other is installing a previous version of QIS.

You can find that from the PyPI website.

0
Comment actions Permalink

Thanks Abhinav,

I tried a bit more on this subject:

1. revert back to an older version of python (which worked with qiskit), and it did not make any difference

2. installing qiskit-aer, it actually installed, however it did not help overall since i still missing qiskit

So I would suspect that perhaps the latest qiskit somehow not working well with my latest python.

Do you know how to install an older version of qiskit?

 

best,

 

dave

0
Comment actions Permalink

To install an older version
Go to PyPI website and look for older versions of whichever library you want.

0
Comment actions Permalink

it worked with the following consideration:

1. pip install qiskit 0.7.0 works, pip install qiskit 0.8.0 does not 

2. here is the qiskit modules that installed and NOT installed.  the ones in blue are installed successfully.  the ones in black can not be installed.  only an older version can be install in my case

3. I am not sure if my case is unique.  if it is, i like to know what i have done/undo to make it work.

0

Please sign in to leave a comment.