can't pip install qiskit

In the terminal mode in Pycharm

Try to:
pip install qiskit

I got:
"Collecting qiskit
Could not find a version that satisfies the requirement qiskit-aer==0.1.1 (from qiskit) (from versions: 0.1.0)
No matching distribution found for qiskit-aer==0.1.1 (from qiskit)"

I am using:

  • Qiskit version: latest version
  • Python version: 3.7
  • Operating system: windows 10

This may not strictly PyCharm related, as I also run it at cmd, and I got the same error.

I also posted this on Github.

Comment actions Permalink

Had the same error, but did not find a solution online (all mentioned that I need 3.5 or above version of Python).

One solution is building Aer 0.1.1 from source and then installing QIS.

Other is installing a previous version of QIS.

You can find that from the PyPI website.

Comment actions Permalink

Thanks Abhinav,

I tried a bit more on this subject:

1. revert back to an older version of python (which worked with qiskit), and it did not make any difference

2. installing qiskit-aer, it actually installed, however it did not help overall since i still missing qiskit

So I would suspect that perhaps the latest qiskit somehow not working well with my latest python.

Do you know how to install an older version of qiskit?





Comment actions Permalink

To install an older version
Go to PyPI website and look for older versions of whichever library you want.

Comment actions Permalink

it worked with the following consideration:

1. pip install qiskit 0.7.0 works, pip install qiskit 0.8.0 does not 

2. here is the qiskit modules that installed and NOT installed.  the ones in blue are installed successfully.  the ones in black can not be installed.  only an older version can be install in my case

3. I am not sure if my case is unique.  if it is, i like to know what i have done/undo to make it work.

Comment actions Permalink

My friends after HOURS of trying different things. I eventually found a work around. For some reason Qiskit does not want to install with just pip, it either has to be installed with pip and Microsoft Virtual Studio (MVS, used 2019) or with the pip variant of MVS. It is possible to install via MVS on the Anaconda Root enviroment, but for whatever reason PyCharm does not want to integrate this root enviroment. So what you can do is: 

1: Create a new Conda enviroment in PyCharm

2: Copy the filepath and import this enviroment into Microsoft Virtual Studio

3: Go to manage packets in Virtual Studio, and select Packages (PyPI) instead of Conda

EDIT. 3.5: Install cmake before you go for Qiskit. Install it in the same way as at point 5.

4: Search for Qiskit

5: Do not click on "Run command: pip install qiskit" however look for the "Install qiskit (CURRENT_VERSION)"

6: Click this one, and let the magic happen. After install you can go back to PyCharm. Good luck travelers, may our hunts be rewarding and plentiful.

Edit2: Install Matplotlib. use print(circuit) after or instead of circuit.draw()


Please sign in to leave a comment.