Was first unable to bring in bcrypt so tried to use internal download of SDK, now getting "Failed to download SDK Unpacked SDK is corrupted"

Hello,

    First I was using an install of the SDK I manually downloaded and added to my env variables (Windows 10), everything has been working just fine until now (have been learning Go, so have not really done much outside of the fmt package). I went to use bcrypt but it was not adding it to my file under imports, so I went to check everything and make sure it was ok with my env, and the settings in GoLand, it looked find but I went to internally let GoLand download the SDK, which it does, begins to extract, but then stops with the error of: Failed to download SDK Unpacked SDK is corrupted. Retry. I tried it a few times with the same results. I tried manually download the SDK again fresh and use that by setting the source of GOROOT and what not in GoLand, but I still end up with the same original issue of not being able to bring in the bcrypt package.

 

I tried running GoLand as a normal user, as well as Administrator, both have the same result. I use an NVMe SSD as my system boot drive that I try to keep fairly clear and have most installs on one of a few alternate 1tb SSD's (both GoLand and SDK were installed to U:\ drive (GoLand: U:\JetBrains\Toolbox\apps\Goland\ch-0 and the SDK: U:\_dev\_sdks\go) in case that somehow ends up being of concern.

Also, not sure if this matters either, but when I try to follow the Go install instructions of :

$ git clone https://go.googlesource.com/go
$ cd go
$ git checkout go1.12.4
$ cd src $ ./all.bat

I get another issue of: 

PS U:\_dev\sdks\go\src> .\all.bat
ERROR: Cannot find C:\Users\Me\Go1.4\bin\go.exe
Set GOROOT_BOOTSTRAP to a working Go tree >= Go 1.4.

Which seems a bit strange, that it's looking in a place in which I have nothing related to go. Perhaps they didn't update something properly with their script? I will try and adjust it manually. 

Thanks,

-MH

2 comments
Comment actions Permalink

Please capture IDE logs via the `Help | Collect logs and show in <file browser>` action and attach them to the ticket

 

0
Comment actions Permalink

I appreciate you getting back to me on this. Over the last several months I found myself spending more and more time trying to get applications working with Windows 10's WSL, and it began being more time consuming trying to get things working together than actually working on my projects, so over the weekend I decided to finally be done with windows and I have switched fully over to Linux Mint. As such, I no longer have any of the issues I had before, so fortunately, this is no longer of concern.

Thanks!

-MH

0

Please sign in to leave a comment.