synchronizing files takes days and doesn't stop

After latest PHPStorm update to 2019.1 version phpstorm is "synchronizing files". Small icon on bottom-left of window is turnigng around.
This process uses ~50% CPU all the time, heating my laptop and, what's worse, many functions of IDE are not working (ie. most of code coloring, some autocomplete functions).

This has started right after update and is working for 7th day 8-12h/day, so i don't think it is normal even for quite big project.

Any idea what's wrong? maybe i have to restart something? kill something? I've even tried to remove unused plugins, but i haven't installed many, so most are just built-in ones.

0
14 comments

Any symlinks or mounted network shares in a project? Please backup your project's /.idea folder & remove it - would it help? 

Please try disabling all custom plugins at Settings | Plugins > Installed > #custom, restart IDE and check the issue after that. 

0

If i close project, open another one, then again this one, it will synchronize for few minutes and will work fine then. But if I close PHP Storm and open it again, and PHP Storm will reopen last project (this one) it will again start synchronizing and will keep doing it forever. I have to close project again and reopen it.

Even after deleting .IDEA directory it is same, it works fine first time, but i have to close project and reopen it every time i start PHP Storm if i want all features.

I also don't have custom plugins installed right now.

0

Are there any external programs exist that may change your project files apart from PhpStorm?

Also, you may want to try disabling "Synchronize files on frame or editor tab activation" in "Appearance & Behavior | System Settings" and check if it helps.

0

Disabling this option didn't help.

But i've uninstalled completely phpStorm, removed every trace of it i could find and then reinstalled program, not it works OK.
So it had to be some setting (or garbage) that is project indepentent i think.

0

Thanks for the update, glad to know that things are working fine now. Just a short question though, do you have a Linux-based installation by the chance?

0

Both Windows and Linux in same time.

I'm working on Windows (PHP Storm is on Windows), but it is also host for VM using Vagrant (and VirtualBox) running Debian and files in public_html on this vagrant/debian machina are mounted from host on windows system.

0

HI. I've faced with smth similar. During update from 2019.2 to 2019.4 after closing IDEA the window "backing up files..." never stoped. The Slack kept smth from IDEA files because everything became good after closing it. my comp is mac

0

That seems to be another problem: https://youtrack.jetbrains.com/issue/IDEA-215497.

Do I get it right that you have this issue only during 2019.2 > 2019.3 update? If it's still happening - just install version 2019.3 anew from https://www.jetbrains.com/phpstorm/download/

0

I'm on a macbook pro (16G RAM and SSD disk) and I've recently upgraded to 2020.2. The synchronization problem is still an issue.  I've tried to delete .idea folder. There are no other external program touching files.   
After synchronization is finished, if I close phpstorm and I open again the project, let's say after 30 seconds, synchronization starts again and takes several minutes. 
I've tried to mark almost every folder as "excluded". It does not work.
Why it takes so long?

0

Fabrizio, if this behavior persists after File | Invalidate Caches / Restart | Invalidate and Restart, please submit your logs (Help | Collect Logs and Diagnostic Data) within a support ticket.

1

I uninstalled IntelliJ and ticked the boxes for deleting cache and plugins too.

I downloaded the last version, installed it (clean of all custom settings & plugins) and now it synchronizes.✅

0

Same here. Annoying as hell...

0

Richard Lalancette, the same here; without troubleshooting data, we won't be able to help. If the issue persists after File | Invalidate Caches | Invalidate and Restart, please submit a support ticket (Help | Contact Support) attaching your logs (Help | Collect Logs and Diagnostic Data). Thank you!

0

I was having a similar issue in PyCharm 2022.3, where the spinning wheel in the lower left corner of the screen would never stop. The tool-tip for that wheel was "synchronizing files". I updated to 2022.3.1 with no change in behavior. I demonstrated that other projects did not have the same behavior, but closing and reopening the same project, the behavior persisted. I tried disabling certain plugins, disabling certain settings, to no effect. Finally, at Eugene Morozov's recommendation, I invalidated the caches:

File | Invalidate Caches | Invalidate and Restart

This worked for me, and I no longer see the spinning wheel.

0

Please sign in to leave a comment.