Problem with debugger

Hello, I have a problem with pycharm debugger on a flask project. I use proffesional vs, Build #PY-191.6605.12, inside Ubuntu.

All worked well, but one week ago, without any settings change, plugins installation and no previous warning, breakpoints of pycharm stopped working.

I tried "solution" from this post: https://intellij-support.jetbrains.com/hc/en-us/community/posts/360003410139-2019-1-and-Pyside-1-QThread-debugging-not-working-solution-, but it does not work for me... any idea?

3 comments
Comment actions Permalink

Also having problems with Debug / breakpoints after a year of everything working ok. I tried the same potential fix - did not work for me on any of settings.

0
Comment actions Permalink

Hi,

There's too many possibilities why the debug might no work. For example, take a look:

https://youtrack.jetbrains.com/issue/PY-35010

https://youtrack.jetbrains.com/issue/PY-35332

So to understand your case, please provide detailed report of the issue:

- Which project interpreter are you using

- Code sample used to reproduce the issue. Ideally - minimal working project example

- Any other specifics regarding your project

- Logs collected after reproducing the issue (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files)

You can upload files to our FTP: https://uploads.services.jetbrains.com/

0
Comment actions Permalink

Thank you for your response, Andrey. 

My problem is related with issue:

 https://youtrack.jetbrains.com/issue/PY-35010

I have the problem on a flask project with python3.7 on virtualenv. For people with this issue, with remove the exec permissions of the python script file (chmod a-x) is enough to get debugger working again.

 

0

Please sign in to leave a comment.