"The project at .. uses a non-standard layout and cannot be attached to this project" since update to 2019.1

Answered

Since the 27.March update it is no longer possible to attach other folders to an opened project. No matter what type of project i have in the folder i'm wanting to attach, i always receive the same message:

"The project at /home/user/projects/test1 uses a non-standard layout and cannot be attached to this project"

 

** Info: **

PhpStorm installed via snap on Ubuntu 18.04.2

PhpStorm 2019.1
Build #PS-191.6183.95, built on March 27, 2019
Licensed to **********************************
Subscription is active until ****************
JRE: 1.8.0_202-release-1483-b39 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.15.0-47-generic

5 comments
Comment actions Permalink

Thanks for a report. I've submitted this as https://youtrack.jetbrains.com/issue/WI-46212. Feel free to vote for or comment it in order to get notified about its updates. 

0
Comment actions Permalink

I can confirm this issue. It happens for me on PhpStorm 2019.1.2 when i clone new repository and want to attach project to existing window but i get message `The project /home/user/..../... uses a non-standard layout and cannot be attached to this project. Would you like to open it in a new window?` and it's not possible to attach it. 

I found some workaround. I opened cloned project in new window, next closed all windows, reopened phpStorm and opened this new project with File -> Open and selected attach - it worked.

0
Comment actions Permalink

Thanks for sharing the workaround, Lukasz!

Shortly speaking, the issue happens if there is no .iml file (or no /.idea directory at all) in the project directory. However, when you manage to open this project for the first time (f.e. in the new window), the .idea directory is created automatically and the project could be attached now.

 

3
Comment actions Permalink

Had the same issue with PyCharm on the May 7th build, and the same workaround worked for me.

0
Comment actions Permalink

I also had this issue with PyCharm May 29th build.  The work-around above worked for me as well.

0

Please sign in to leave a comment.