Intellij IDEA cannot resolve any import statement


Hi there,


I am struggling recently with very strange issue. Suddenly, my intellij IDEA stopped resolving all java import statements.


The only solution that worked so far for me was to uninstall intellij IDEA and install it again. Although, when I import one of my projects upon ~4 hours it cannot resolve any import statement again. This happes only for that one project. It is Eclipse RCP based.


Unfortunatelly, I cannot share with you the source codes of that project.


What I have already tried is the following:

  1. Remove .idea folder
  2. Remove all *.iml files
  3. Invalidate and restart

None of this works for me. When I create project from the scratch it also tells me that import statements cannot be resolved


My intellij IDEA version: 2019.1 Ultimate



It cannot event resolve base classes like String


My SDK is set up properly


Thank you for your help.




Hello Jjurco Sk,

The issue is not yet reproduced on my side. Can you please check if your JDK 14 version has "java.sql" (you may check it in Project Structure | JDKs)? Thank you 


Yes, I do have it. I'm also able to run the project through Idea. 

In the afternoon I'm going for holidays so I may not be responsive for some more than week. 


Hello Jjurco Sk

Can you please share the idea.log file (Help | Show Log in Finder, may be uploaded here: and take the screenshot of how the "unfound" library looks like it the Project Structure view. Does java.sql have folders, classes there? Thank you 


Please also try to enable the following option "idea.invalidate.caches.invalidates.vfs" in the Registry before the invalidate/restart and check if it helps:

Thank you and sorry for inconvenience.


I'm having same problem as most with 2020.2 release.  I have to "invalidate cache" periodically for my "import static" to resolve.  Is there a fix?  I have monitored this thread and I do not see any indication that this is a bug.  Does anyone have any idea on how to fix this issue


Delete the System directory: when the IDE is not runing and see if it helps.

If the issue persists, file a bug at with the screenshot of the issue and the logs attached (Help | Collect Logs and Diagnostic Data).


Thank you. I have done as you’ve requested. If the problem persists with this release, I will open an issue with screenshots and logs.


In my case File -> Invalidate Caches/Restart... alone helped without deleting .idea folder and *.iml file  jazz.


Just to add my 5 cents to the discussion. None of the suggestions seemed to fix my issue. I've tried reinstalling the IDE, changing the version and nothing helped. In the end, I found out that somehow my JDK got uninstalled from my PC (it was separately installed, not as part of IntelliJ), which was the cause for the IDE not locating classes from the Java core libraries. I'd suggest in addition to the other solutions, to make sure there is a valid JDK on the machine and the IDE is pointing to it.



Please try to delete  C:\Users\<user_name>\AppData\Local\JetBrains\IntelliJIdea2020.X\  folders all together if you are in Windows.

No worries those necessary will be recreated.



I had a similar issue , I resolved it by changing the java version that intellij uses to java 11. This will happen if we have mentioned different java version at different places in intellij. 
Make sure the java version is same in all the places 
1. File -> Project Structure -> Project -> Java 11 (Example)

2. File -> Project Structure -> Modules -> individual project module -> Java 11 (Example)

3. File -> Project Structure -> SDK's -> Java 11 (Example)

4. Intellij -> Preferences -> Compiler -> Java Compiler -> Java 11 (Example)

This is in Mac intellij, making sure i use same Java version in all the above locations resolved this issue for me. Hope this helps .


Hello, please try the latest IntelliJ IDEA version, the issue with unresolved imports from JDK must be resolved there:


Do we have solution for that? I got that problem after upgrading to 2021.1 :( so far nothing helps...



Please file an issue to our YouTrack: and attach the log files to it, we'll investigate the problem. Thank you 


I have same issue with IntelliJIdea2021.1 Ultimate. (windows) not recognizing some imports and say 'Cannot resolve symbol xxx' and shows red.  

SpringBoot project Maven project. It compiles with 'mvn clean install' from command line and Intellij Maven build.

The all errors seem to be in annotation package.

Project Setting using : ProjectSDK=11,  Available SDKs: C:\pkgs\JDK\openjdk11.0.8.10 (11) and C:\Program Files\Java\jdk1.8.0_74 (1.8)  available.

File | Settings | Build, Execution, Deployment | Compiler | Annotation Processors  for the project (not default) set to "Enable Annotation Processing" , "Module content root" with "Production sources directory" : "target\generated-sources\annotations" , "Test sources directory": "target\generated-test-sources\test-annotations"

Some of the things I have tried.

I removed .idea directory and *.iml files from project.

removed C:\Users\<userID>\AppData\Roaming\JetBrains\IntelliJIdea2021.1

Deleted the C:\Users\<userID>\.m2\repository and rebuild the project on command line.

"Invalidate and Restart"

Restricted environment at work so I'll have to see what I can upload.  Please suggest any other ideas :) (pun intended)


Is it possible to share idea.log ("Help | Show Log in...") after restarting ID and running "Reload" from Maven Tool Window?


My problem is that I update the IDEA and all imports are not working.

Thank god. File -> Invalidated Cache and Restart save me.



Wanted to put in my fix in case it helps anyone. I deleted my target file and ran a clean build. All imports are working as expected. This was after update 2021.1



I'm just a newbie, but I had basically the same Porblem on my Android Project for my University course. To resolve this issue i just had to select (and apply) a different Project SDK in the Project Settings and then I had to switch back to the old one and the issue was gone.

Hope this will help someone.


I was also facing the same issue I tried almost all the suggested ways from different platform. Finally File -> Invalidate Caches/Restart worked for me... and issue got resolved.


Had similar problem after upgrading Intellij. Was the SDK that had gone missing, because I used the embedded JDK.


I face the issue sometimes, when i created a new project witrh an preselected sdk.

it helped to just change the sdk to something and than back to the one i want to use.



For whatever it's worth, on my Maven project I had to:

Right-click pom.xml -> Add as Maven project

I hope this helps someone!


After struggling for literally 1 week, I finally found the solution. I tried so many permutations & combinations suggested in so many threads, but nothing actually worked for me.

Here's the thing:

IntelliJ is showing the errors because the dependencies are internally messed up. It doesn't mean they don't exist! They do, but mixed up. If there is an internal conflict with the wrong existing dependency, IntelliJ blindly skips it - which causes these huge errors for us.

Best course of action, according to me is: Delete all the contents inside .m2 repository & re-run maven clean install from terminal. Then re-load projects in IntelliJ


Its unfortunate that it still happens in 2022.


Shekhar Sahu

Different things can cause this, that's why there is no intuitive solution or universal preventive measure for it yet. We are working on improving the situation.


After about 7 hours messing around with this issue, (only some imports were not resolving, and they were there right there in the project directory structure and no reason resolving imports should have been an issue)

File -->  Repair IDE

finally did the trick for me.


So this one was a nightmare, but I found something that worked for me.  After I made sure my local java version/location was pointing to the correct JDK (which was important), I tried restarting, rebuilding, reconfiguring, deleting and reinstalling, and basically everything in this thread.  Decided to remove the Maven m2 folder, and low and behold the project started reinstalling all dependencies automatically because they didn't exist anymore.

rm -rf ~/.m2/

I almost cried I was so happy.


SOLUTION for me: switch maven version from bundled to the OS included one. 

I had this problem of lots of packages not being resolved after a large-gap upgrade (2021.something → 2023.3.4, in a couple of steps - but immediately one after the other). All my projects are maven. All those I looked at had the problem. I had decided to catch up to the latest IDE just a few days after an OS upgrade Ubuntu 20 → Ubuntu 22. But the 2021 IDE did work after the OS upgrade.

Seems clear the problem was with reading the maven local repo. It did appear, seemingly correctly, in Build→Maven→Repositories, but hitting the Update button resulted (eventually) in an “Error scanning context repository-…”

Command line maven builds worked perfectly well.

Things which did not help:
- Reloading the project.
- Reconfiguring to a different JDK (separate problem I think: all the modules in my project had been reconfigured to use Java 1.5 - the project is 1.8)
- Removing the project (the one I want to work on now) from local repo and recloning from git remote in new local location, then readding (IDE doesn't seem to use the word ‘import’ any more).
- Flushing caches and restarting.
- Brand new installation of IDE (Ultimate) 2023.3.4 which used in place of the upgrade-in-place 2023.3.4 where originally had the 2021 IDE.

Things I did not try:
- Clearing all my user setting files for the IDE.

What worked:
- I that I added the command line default maven installation (Home: /usr/share/maven), by hitting the 3 dots next to the drop down. The drop down showed the path (instead of “Bundled (Maven 3)” ). When I applied this it seemed to force a reindexing and the problem disappeared.
I then switched back to the Bundled and the problem did not reappear.
BUT this new  Maven config disappeared again. It no longer appears as an option in the dropdown for some reason.


Please sign in to leave a comment.