Autocompletion nodejs node_modules ( Please Help )

Autocompletion does not work with node_modules but works fine with globals like fs , ... etc
why !?

9 comments
Comment actions Permalink

It works fine for me in 2019.1, validator 10.11.0:

 

what IDE version do you use? Did  you try invalidating caches?

0
Comment actions Permalink

Okay, once i updated to version 19.1. it works like a charm. thank u <3 

1
Comment actions Permalink

Im using webstorm 2019.2 and it's not working ... :(

0
Comment actions Permalink

not an issue for me in 2019.2:

Please try invalidating caches (File > Invalidate caches, Invalidate and restart)

If it doesn't help, please share a sample project that shows up the issue

0
Comment actions Permalink

It works now but i had to install the librairie NPM in webstorm (@types/npm). Is that normal ?

0
Comment actions Permalink

No, npm typings are not required unless you like to get completion for NPM library itself

0
Comment actions Permalink

Same problem here with 2019.3.1 under debian (linux mint 19.3). Auto completion does not work with node_modules but works if i download globally pakages (@types/npm). I tried with npm or yarn, but it is all the same.

EDIT

OK, problem solved: you have to right click the node_modules folder then Mark as... / Not excluded.

1
Comment actions Permalink

Windows 10. WSL.

I've just updated Webstorm to 2019.3.4.

Same issue:

 

0

Please sign in to leave a comment.