External Libraries indexing

Setup: PyCharm 2018.3.2, Windows 10, Ananaconda Distribution of python

When I run `python -m venv venv` to create a new virtual environment the `pyvenv.cfg` file assigns the home variable to be

home = C:\Anaconda3

This wrecks all kinds of havoc during indexing because PyCharm indexes EVERYTHING which includes a dozen conda virtual environments. Even without conda environments the Anaconda Distribution is huge.

The annoying thing is that this information is not that useful (I think but you can correct me).

Any help to turn off indexing of the home variable would be helpful.

 

To test, I activated another environment and used that to create a new virtual environment. The virtual environment shows up in external libraries and takes seconds to index.

 

1 comment

Hi,

PyCharm 2018.x had some issues with Anaconda, which was fixed in 2019.x

Please try the latest version (Download PyCharm)

If the issue is still reproduced, please provide detailed steps to reproduce the issue starting from scratch.

0

Please sign in to leave a comment.