Git SSH Executable option missing

Hello,

recently I have switched from 2018.3.5 to 2019.1.1 and since then, I can't pull/push anything from the git repository via SSH. In previous version I managed fix that issue by setting SSH Executable to "Native", but in new one the option is missing.

Could you tell me how can I use Git Integration with SSH in current version?

9 comments
Comment actions Permalink

Hello. Since 2019.1 we're using "Native" all the time. What error are you getting on pull/push? You might want to investigate this with support via Help > Contact Support. Might be something similar to https://youtrack.jetbrains.com/issue/IDEA-210651

0
Comment actions Permalink

This sounds suspiciously like a problem I'm having. I opened a case with JetBrains (request #2106782) for assistance.

0
Comment actions Permalink

I am having a problem in the webstorm 2019 that is related. In webstorm 2018, I was using built in ssh executable. When I updated to 2019, my git connection broke to my private repo on bitbucket. I get this error when trying to pull:

11:47 Update failed
Unauthorized
Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

 

When I switch my webstorm 2018 preference to native from built in I get the same error in 2018. So my problem must be the native ssh executable. How do I fix it? I'm on a macbook pro running mojave

0
Comment actions Permalink

Joshua, when you run git fetch via Terminal in the same project directory, what is the result?

0
Comment actions Permalink

hm, I seem to get this:

-----

git fetch
Unauthorized
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

-----

But in webstorm 2018 with built in ssh executable, I can fetch with the webstorm ui, which is what I usually use. In the past, I have used the command line to do some things with git and access to the remote repo. I don't know what changed. Any ideas for me? I tried adding my private key identity (ssh-add ~/.ssh/MY_KEY) and that didn't help

0
Comment actions Permalink

Ok, I got a little further. I was apparently not adding the ssh identity right. On macOS you need to add the -K flag when using ssh-add. So now I have git fetch working in terminal. But not in webstorm 2019

0
Comment actions Permalink

Is it possible that you were using any credential helper? Starting from 2019.1.1, it is not used by default anymore (an option -c credential.helper= is passed)

Here is the short instruction on how to revert the old behaviour back:

https://youtrack.jetbrains.com/issue/IDEA-211251#focus=streamItem-27-3418235.0-0

0
Comment actions Permalink

I have the same problem:

Despite using ssh key, I am being asked for a password

And no this issue is not the same as https://youtrack.jetbrains.com/issue/IDEA-210651

And yes git fetch works perfectly fine out of an other terminal than the idea's built in one.

I wasn't using the credential helper. At least not explicitly. It seems to be the problem though. This https://youtrack.jetbrains.com/issue/IDEA-211251#focus=streamItem-27-3418235.0-0 doesn't solve my problem as there is no registery beginnning with "git.reset...." as mentioned under the aforementioned link.

You obviousely have changed the default behaviour and leave your users with a lot of problems and are not able to provide a solution. This makes me FUCKING ANGRY!!! I was always very satisfied with your products but cannot understand this desicion at all

0
Comment actions Permalink

Peyman Khodadust the problem with broken rsa key-based authentication can be solved for the "native ssh" client by creating a proper ~/.ssh/config file with the path to the key for your user account on each of the git servers. It works with gitlab on Windows and since the original recipe was made for Linux - it should work on Linux as well. I just fixed my Windows system that way (and came across your post here while searching why the "ssh executable" option is missing just to learn the "navite ssh" is the only client available in recent versions). Credits go to https://www.keybits.net/post/automatically-use-correct-ssh-key-for-remote-git-repo  but the link is already dead..

In ~/.ssh/ create a file called config with contents based on this:

#user1 account
Host github.com-user1
    HostName github.com
    User git
    IdentityFile ~/.ssh/github-user1

#user2 account
Host github.com-user2
    HostName github.com
    User git
    IdentityFile ~/.ssh/github-user2

Replace user1 or user2 with your GitHub usernames

0

Please sign in to leave a comment.