How to disable autocompletion on schema names?

Answered

When I double click the left side bar to enter a table under a schema, it automatically run two commands -- 'use SCHEMA_NAME' and 'SELECT t.* FROM SCHEMA_NAME.TABLE_NAME t LIMIT 501'.

 

How can I disable the autocompletion of the SCHEMA_NAME, which allow me can do this operation only by run command like 'SELECT t.* FROM TABLE_NAME t LIMIT 501'?

 

We have a db proxy in our company and it will go wrong when execute command with SCHEMA_NAME prefix.

 

Thanks for the help.

4 comments

Am I right that now you just can't get the data editor because generated queries don't work?

0

@ Maxim You're right. Is there any way to disable this feature? It's not necessary when I  configure the database in the datasource panel.

0

I found this issue: https://youtrack.jetbrains.com/issue/DBE-3194

 

But it seems that this option doesn't work when access a table via GUI.

0

Unfortunately, there is no workaround for this. Please follow the ticket: https://youtrack.jetbrains.com/issue/DBE-8196

0

Please sign in to leave a comment.