Stop setting up projects as virtual environments in PyCharm

I don't know how I did this and since when this is a feature, but PyCharm is setting up every project as a virtual environment so I have to manually put in all packages I want to use before importing them as it is a separate environment from where pip installs packages.

 

Is there a way to disable this? I clearly missed it.

1 comment
Comment actions Permalink

You don't have to use virtual environment if you don't want to.

You can select a "System interpreter" for a project, which will use your global environment. See here for more info: https://www.jetbrains.com/help/pycharm/configuring-python-interpreter.html

You can also create virtual environment which inherits packages from the global environment. 

0

Please sign in to leave a comment.