can't get xdebug work with laravel and phpstorm

hi good day every body i had a problem with my phpmyadmin and i  remove my xamp and install a new one

after setting all things then i want to to set the things for xdebug as usual but it doesn't fix at all i can fix it for one php file but can't fix it for my laravel projects

this is my php.ini config file for xdebug section

and it would be like this if  i call a route

 

i am struggling with in 4-5 days and can't figure out what is wrong with it i even install different version of xampp and wamp

6 comments

Do you have breakpoints in your project?

Try to close PhpStorm and check if your Laravel project loads.

If that's not the issue - please try to illustrate the problem in more details.

0

yes i put breakpoints in project and as soon as put breakpoints in project it would be like

just loading and loading and when i end php artisan serve in phpstorm terminal and clean the breakpoints it would work normal again

this is my php.ini file settings for xdebug part

[xdebug]
zend_extension = C:\xampp\php\ext\php_xdebug-2.7.1-7.1-vc14.dll
xdebug.remote_autostart=1
xdebug.default_enable=1
xdebug.remote_port=9001
xdebug.remote_host=127.0.0.1
xdebug.remote_connect_back=1
xdebug.remote_enable=1
xdebug.idekey=PHPSTORM

what part of config or setting do you want me to send picture for you?

 

0

i realize it brings this page

server.php but with stop request the request would fail but with next just go to pause and it never get complete

0

Hi there,

What's your IDE version?

What do you have in "Settings | Languages & Frameworks | PHP | Servers"? Try deleting that entry and start from scratch (let IDE help creating an entry there; it will do that when it sees next debug session).

0

phpstorm 2018.2.7
i did empty the "Settings | Languages & Frameworks | PHP | Servers" but it doesn't change anything

0

Accordingly to your info, you are using Xdebug 2.7 .. which requires PhpStorm 2018.3 or newer. Either upgrade IDE to newer/latest version  or downgrade Xdebug to 2.6.x

1

Please sign in to leave a comment.