Best practices for packaging a plugin that uses JAX-WS, etc., to work under both Java 8 and Java 11 JREs

Answered

My custom plugin uses Apache CXF to invoke external SOAP services via WSDL-generated clients, and CXF uses JAX-WS. Java 11 no longer bundles the J2EE jars, so my plugin doesn't work in 2019.1 when used with the Java 11 JRE.

I'm trying to figure out the best way to package my plugin with all required dependencies--ideally as a single distribution--so that it will work under a Java 8 JRE which includes these jars and a Java 11 JRE which doesn't.

Is anyone else experiencing this same issue? If so, any thoughts on how to deal with it?

2 comments
Comment actions Permalink

Thanks, Yann. I posted this question in a few different places when I didn't see any response on it for almost a week during which I was fielding a growing number of support issues because of it. I'll focus all of my attention on the linked YouTrack issue now.

0

Please sign in to leave a comment.