invalid private key in connection settings

1. read the cloud provider instruction 

Add your SSH Key

SSH Keys are a secure way to log into your instances through SSH. To generate your key, run ssh-keygen -t rsa -b 4096 -C "" in your terminal.

2. generate keypair and add public key to server

3. try to add private key in PhpStorm


Comment actions Permalink

Unfortunately, the SSH lib we're using (Jsch) does not support this type of keys.
Please use ssh-agent as a workaround:

We're working in swapping the library for another one:

Comment actions Permalink

Seems like PY-35528 issue was removed. Is there an issue for the problem? I'd like to vote for it

Comment actions Permalink

Yevhen Saklakov, PY-35528 is not visible to the public, but it's been fixed in 2019.2 - we are using SSHJ instead of JSch for a while now. We also don't have many new invalid privatekey reports:,web,idea,ideabkl,ruby,py,dbe,jbr%20%22invalid%20privatekey

Please add #com.intellij.ssh to Help | Diagnostic Tools | Debug Log Settings, reproduce the issue, and then submit your logs (Help | Collect Logs and Diagnostic Data) in a support ticket (Help | Contact Support).


Please sign in to leave a comment.