Jupyter run configuration no longer works after upgrade to 2019.1

I have upgraded my PyCharm 2018.3 to 2019.1 (professional), which has broken all Jupyter support.

My projects have a run configuration for Jupyter that I would start separately, so I could view and edit my notebooks in Chrome due to the abysmal support in PyCharm itself.

Upgrading to 2019.1 for some reason invalidated those run configurations meaning that I can no longer start Jupyter with the configurations that worked fine before the upgrade.

 

The newfangled "Managed" Jupyter sever does not start either. After opening a notebook in the PyCharm IDE, PyCharm will try to "auto-launch" the "Managed Jupyter server", and fails with a "Run Error" that is entirely unhelpful in actually telling me what is going wrong:

After this error message, opening the Jupyter URL in Chrome shows a blank page.

On top of that, there does not seem to be a way to just start the Jupyter server without having to open the notebook in PyCharm itself, which is what I don't want to do.

Short of downgrading to 2018.3 again (which is going to happen if there is no easy fix), how do I get Jupyter working again? It was working flawlessly before, and now I'm stuck.

It seems like you haven't done any testing on upgrade scenario's :-(.

3 comments

Hi,

Jupyter support was completely redone for 2019.x release. It's not using run configurations anymore.

Regarding managed server, please try to run it again, reproduce the error, and provide log file (Help > show log in...) 

 

Before you do, however, here's some troubleshooting you can try:

1. Ensure port 8888 is not used by another process

2. Kill all python.exe processes that might be running in the background, then execute the cell

0

Removing support for existing run configurations is breaking functionality in existing projects without having an equivalent alternative in place. That is a regression.

  • The integrated client does not offer all the functionalties of the web client, especially for large interactive visualizations which I use a lot.
  • The integrated client forces split editing. I prefer the in-place editing offered in the browser.
  • It is not possible to launch Jupyter other than from a notebook opened in PyCharm.
  • It is not possible to define parameters for launching Jupyter, e.g. specyfing the port number.

Honestly, it seems that the Jupyter runner was only removed because it was deemed "too useful" for the community edition. From where I'm sitting right now, you have removed a free tool that functioned well because it competed with an inferior commercial implementation that is still flawed (even though improved from 2018.3)

The screenshot attached in my original message shows the 8888 already in use error because there already is something in use on that port on my PC that is not Jupyter (imagine that). That's why I have a different port specified in my Jupyter run configuration.

I have rolled back to 2018.3 for now, as I need a working Jupyter installation for my daily work. Once I re-evaluate 2019 I will update with new information.

At least it should be possible to easily launch Jupyter from the IDE with an option to define the startup parameters. Make it a "professional-only" option if you have to, but give us an option to not use the Jupyter environment if that suits our needs. It was there in 2018.3, it worked perfectly.

0

Hey Bram,

Thanks for your feedback. Indeed there's currently some features lacking that can be found in the native web interface of Jupyter. You can see the pending feature requests we have:

http://bit.ly/2XQPI7T

We plan to gradually implement them, improving our Jupyter support.

0

Please sign in to leave a comment.