Changed files are not shown in local changes window

Answered

Im using intellij community 2019.1 with git. Suddenly all the files turned to gray color, and git local changes doesn't show anything( git status from terminal shows everything properly)
I tried restarting, invalidating cache, making sure git root directory is set and what not. How can I fix that?
Recently I checkout from a svn repo for the first time - could that be the readon?

2 comments
Comment actions Permalink

> Recently I checkout from a svn repo for the first time - could that be the reason?

Checking out and svn repo should not cause this unless you check it out to the exact same folder where git repo is, and now the same fleas are both controlled by git and svn.

Make sure mappings are correct and not conflicting in Settings | Version Control. If it is not the case, please submit a request to https://youtrack.jetbrains.com/issues/IDEA with the logs folder attached. See https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files to locate logs.

0
Comment actions Permalink

you can go to settings, ctrl+alt+s -> version control -> confirmation : change the options of "when files are created".

also if it doesn't solved the issue you can right click on your project in intellij, go to subvertion> edit properties. check if there is a property named "ignore" or "global-ignores" with "*" value, remove "*" in these properties.

0

Please sign in to leave a comment.