Why it's updating indices again and again? making it unusable at all

Answered

The ide is "Updating Indices" of JDK, 3rd jars, .gradle/ folder etc again and again and again when openning the project.  It takes too long time, and cannot be canclled. Making IDEA totally unusable, very very very annoying!

This happening in all versions of idea with gradle plugin.

This feature must be improved, some suggestions:

(1) do not index the same thing more than once

(2) let user to define the exclude-set of indexed folders

(3) do not index unused stuffs; try to identify which are unused

(4) do not block user operations when it's indexing

etc

68 comments
Comment actions Permalink

This feature must be improved!!! it makes the best IDE to the worst software in the world...

24
Comment actions Permalink

please fire the guy who made it...he is destroying the product

19
Comment actions Permalink

I agree with Leon my pyharm just finished updating indices for 2 hours then I close and launched again and it is started indices again for hours. 

I am not professional developer or programmer I am an mechanical engineer but I do not understand the logic and need for "indices" operation. 

If it is necessary why Anaconda Navigator's Spyder does not do it. And I see a lot of complaints about it why JetBrains is not fixing it.I paid again for second year but can hardly run "Hello World" program. Can someone again explain what does tgis operation do and why other IDEs do not have it 

5
Comment actions Permalink

Not funny... "Updating Indices - Indexing...", only a few files... waiting and waiting again...

PLEASE IMPROVE THIS!

Can a log tell me, what IDEA is doing the whole time? In htop, I see a lot of PIDs with ~/.local/share/JetBrains/Toolbox/apps/IDEA-U/ch-0/192.16603.28/..., but the progress bar isn't moving and my PC doesn't seem to write to disc. I don't know, if there is any real progress at all...

3
Comment actions Permalink

Hello Yaroslav,

it's easy to reproduce: create an app with some files (in my case Java EE), open it as a project in IDEA. Close IDEA.
Then change some code outside of IDEA and outside of the IDEA project directory, copy all the files with some File-Explorer (Nautilus, Windows-Explorer) and paste it in IDEA into the project. IDEA will start to index and never come back to work.

The reason I want to do this is, that we get source code as war-files and build our local archive and make diffs via git with them.

While that is an "overwrite all" with files, git will only add source code changes, regardless if the files timestamps changed. I will not search for changed files and replace them manually one by one: outside IDEA it's just copy&paste from a new temporary source-folder of the extracted war to the IDEA project folder, then a "git add -A" and "git commit [...]" in the terminal, all done in seconds for our archive to get synced to the external work. Pasting within IDEA into the project directory, my PC is getting useless, because IDEA will index without progress. I had to kill IDEA every time I tried...

1
Comment actions Permalink

cant believe this is happen to webstorm, im proud of picking it as my best IDE and showing off to my collegues, and this updating indicing thing jus kills my reputation...

1
Comment actions Permalink

Dayanshu W

Please also add #com.intellij.openapi.util.io.FileSystemUtil:trace in Help | Debug Log Settings and check what files are indexed in the idea.log (https://intellij-support.jetbrains.com/hc/articles/207241085). You can also submit a support ticket with the idea.log attached, so we could help to find a root cause. 

1
Comment actions Permalink

It depends on the plug-in. Some plug-ins do require indexing, other don't. We are currently working on the new Dynamic Plugins architecture that will make it less frequent.

1
Comment actions Permalink

Back to Eclipse

Update: seemed to be the Vaadin Designer update to 4.5.1 -> be carefull

1
Comment actions Permalink

This problem still exists in latest 2021.1.

I found it is very likely to happen when there are several IDEA instances. All instances will rebuild at the same time, especially rebuild index of JDK11.

If I close other instance and left only one, it will still repeatedly rebuild indexes. The only one solution is close all instances, and reopen them.

This problem is very annoying, hope it can be resolved soon.

1
Comment actions Permalink

>> Could you please update to the latest version and check if the issue is still there? If it is please file a ticket and share log files with us

Hi.

IDEA 2021.2.2 - it looks like the situation has become better. At least I do not remember re-indexing after each project opening last weeks. IDEA after a project opening searches for files for indexing (it takes 1-2 minutes) and checks spring configuration.

Full (and long) re-indexing remains if IDEA was incorrectly closed (killed as process, power was switched off). But I guess this is another case and it happens not so often. 

Thank you for feedback and reaction

 

1
Comment actions Permalink

Vinicius Carvalho Indexing database could be corrupted after crash, that is why we reindex. 

This will be improved a bit in 2021.3, and more improvements will be done in 2022.1 

1
Comment actions Permalink

Hello Jochen,

Please report an issue on YouTrack attaching logs folder zipped (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files) after facing the issue again: http://youtrack.jetbrains.com/issues/IDEA.

 

0
Comment actions Permalink

Jochen,

I don't get long indexing process on my machine after pasting files. Probably some extra steps are needed to reproduce?

 

0
Comment actions Permalink

I'm seeing the indexing problem as well.

In my case, it started after my anti-virus software quarantined these files, which appear to be internal to Intellij:

:cd .IntelliJIdea2019.3/system/index/
:find . -name 'hashes*'
./.persistent/hashesWithFileType
./.persistent/hashesWithFileType.keystream
./.persistent/hashesWithFileType.keystream.len
./.persistent/hashesWithFileType.len
./.persistent/hashesWithFileType_i.len
:pwd
<My HOME directory>/.IntelliJIdea2019.3/system/index

Are these files used for indexing?

 

0
Comment actions Permalink

>Are these files used for indexing?

Yes. Please exclude IDE settings/cache directories, the IDE installation home and project files from the scan.

0
Comment actions Permalink

It happens with me also, in PHPSTORM.

Try to invalidate cache and restart.

0
Comment actions Permalink

Every time a plugin is updated in Intellij Ultimate 2020.1 (and previous ones) it indexes all the maven dependencies again and again.

Why on earth any plugin update will require the index also be updated from scratch??

0
Comment actions Permalink

Hi, 

 

I'm facing the same problem with PyCharm Community on Ubuntu 18.04:

 

* my project folder is /home/my_name/Downloads

* Pycharm try to index ALL the files and folders in my /home/my_name, EVERYTHING, even the .cache, .virtualenv... folders and not only in the project folder

 * so I delete everything in this folder (even the .idea folder), then I restart Pycharm

* and, again, Pycharm indexes ALL files and folders in my /home folder (see image)

Why?

 

Best regards,

 

Philippe

 

 

0
Comment actions Permalink

A question related to this comment here

What is the scope of this full index operation? My IntelliJ seems to be indexing my whole filesystem, as mentioned by Philippe Juhel. Should it be only the opened project? It is indeed really slow.

I'm on ubuntu 19.10 with IntelliJ Ultimate.

0
Comment actions Permalink

This skeleton generation strategy is the most pants-on-head stupid feature I never asked for. I simply don't know what you mean when you advise to exclude the problematic directory from the project roots. PyCharm indexes MY ENTIRE HARD DRIVE. There isn't even an OPTION to exclude ancestral directories from the project sources. The problem lies in the jdk.table.xml file, which includes the root directory of all my Python projects. But when I remove this line, it grows back immediately the next time I restart like kudzu. I HATE THIS SO MUCH.

0
Comment actions Permalink

@Kevin Zeidler

>I simply don't know what you mean when you advise to exclude the problematic directory from the project roots.

If the problematic directory is in your project, then you can right-click it and choose Mark Directory as -> Excluded.
If it's not in the project, then make sure it's not in the Interpreter Paths https://www.jetbrains.com/help/pycharm/installing-uninstalling-and-reloading-interpreter-paths.html

0
Comment actions Permalink

> If the problematic directory is in your project, then you can right-click it and choose Mark Directory as -> Excluded.
It's not - because, again, the skeleton indexes virtually my entire hard drive. Hundreds of thousands of files and directories indexed every time I start a new project. The cache inevitably grows to >50GB unless I manually delete it periodically.

>If it's not in the project, then make sure it's not in the Interpreter Paths https://www.jetbrains.com/help/pycharm/installing-uninstalling-and-reloading-interpreter-paths.html
Interpreter Paths consist solely of descendants of the project root. 

 
To reiterate, the problem lies in the jdk.table.xml file, which includes several problem directories. It is almost certainly related to this file, because when I grep PyCharm dirs for those specific strings, this is one of the only places it occurs (other than log files). I cannot delete those entries. They regenerate the next time I start PyCharm. I even attempted to revoke its write privileges to that file, but that interfered with startup and PyCharm printed an error about being unable to load settings.
0
Comment actions Permalink

Have the same issue for all maven projects

0
Comment actions Permalink

Oleksiyprosyanko

What is your OS / IDE version? Have you tried any of the solutions suggested in this thread?

0
Comment actions Permalink

OS: MacOS Catalina 10.15.6

IDE: Ultimate 2020.2.1

I have this issue for Javas project only or any other project containing Java code.  My Scala projects behaves normally. 

0
Comment actions Permalink

Did not help. I disabled all `Probable bugs` under `Java` inspection.

0
Comment actions Permalink

I managed to solve this by disabling `Settings (Preferences on macOS) | Editor | Inspections | Java | Probable bugs`

0
Comment actions Permalink

I have the same issue on last versions (current 2020.2). I see that most of the time is due to indexing jar of plugins installed even if the plugin is not used in the current project. Several questions here:

- seems jar are indexed seveal times

- why indexing plugins not used by the project ?

- why not providing plugins with an index ?

 

regards,

0
Comment actions Permalink

Jphautin please share idea.log after adding #com.intellij.util.indexing.FileBasedIndexImpl:trace in Help | Diagnostic Tools | Debug Log Settings and reproducing the case

0

Please sign in to leave a comment.