I would like to make my plugin compatible with a wide range of PhpStorm versions.
Initially there were some issues with source code - for instance my plugin was making use of a VoidDataExternalizer, something that was not available in the OpenApi version 2016.1. So I started a new Java package called `compat` with a couple of classes that allow the plugin to run on PhpStorm 2016.1 through 2019.1.
The issue is that even though it is source compatible, it is not binary compatible. That is, I need to build using the 2016.1 SDK for 2016.1.
My question is, is there a known good way to figure out these 'version ranges'? I do not want to end up having to download 20 SDKs and then release 20 versions of my plugin! If I build using 2017.1 (say), and it works for both PhpStorm 2017.1 and 2018.1, can I avoid checking the versions inbetween?