No Command+Q again prompt to quit app?

On most Mac apps I use, hitting Command+Q on accident instead of Command+W (like Chrome to close a tab) will pop up some text saying to hit Cmd+Q again to quit... with PHPStorm it just quits, which is a giant pain in the butt especially when I have to have multiple projects open (often).

Is there some way to have it do this?

I'm not talking about the Confirm Exit which blocks shutdown; just for Cmd+Q accidental hit.

2 comments
Comment actions Permalink

No, there's no separate setting for this.

The problem is discussed at https://youtrack.jetbrains.com/issue/IDEA-148980 (feel free to vote/comment). But I would just rather suggest to remove cmd+q shortcut in Preferences | Keymap: Main menu > File > Exit.

0
Comment actions Permalink

Unfortunately removing Cmd+Q shortcut does not work in IDEA 2019.2 (version I tested); the Cmd-Q behaviour seems hardwired.

My workaround is the wonderful 'Karabiner' keystroke interceptor program for MacOS which allows you to (for instance) 'swallow' Cmd-Q IF it is held for less than 3 seconds, IF the frontmost application bundle is "com.jetbrains.intellij" 

0

Please sign in to leave a comment.