Xdebug is installed but doesn't react.

So, the same song as always - xdebug is installed and "configured", but doesn't react on page refresh. Have examined some topics here, but none of them helped. Then have decided to check wether my xdebug config is ok. I am pretty sure, that, you guys, are faster than me. Would be happy to see any ideas.

Screenshots:

 

 

 

 

Can't figure out myself what is wrong with this thing. Any ideas?

 

 

7 comments
Comment actions Permalink

Hi there,

1) So what Xdebug log has to say about it?

2) What's your IDE version?

1
Comment actions Permalink

1) log file doesn't exist, unfortunatelly

2)

0
Comment actions Permalink

Did you had it working before?

Here is a link from the help: https://www.jetbrains.com/help/phpstorm/troubleshooting-php-debugging.html

If debug log is not getting created .. and assuming that you have configured it all correctly ... then maybe it does not see the "debug me" flag (Xdebug COOKIE or GET/POST parameter).

How do you debug? Does PhpStorm is the one that listens to Xdebug connections on TCP 9000 port? Maybe it's firewall issue?

Will it generate the log file if you add programmatic breakpoint (by putting xdebug_break(); into your code)? Try debugging a simple script first (few basic instructions each on own line).

Without knowing all the setup it's hard to suggesting anything more specific but to check the troubleshooting page first.

Having Xdebug log will get some clues into what else might be wrong/missing. But your settings seems to be OK at quick glance.

0
Comment actions Permalink

so, I started from the easiest one:

xdebug_break();

the result is : 

What should I do?

0
Comment actions Permalink

>What should I do?

Ignore that. That's Composer related suggestion and it does not affect code execution/debug in any way.

0
Comment actions Permalink

one more thing before I start debugging from Troubleshooting page. I tried tp validate, but got some errors (http/https) :

 

 

does this play any role?

0
Comment actions Permalink

1) HTTPS -- certificate used on that site does not declare "127.0.0.1" as a valid name. Normal thing. Try accessing website using the name from certificate.

Not sure if adding that certificate to "Settings | Tools | Server Certificates" will help.

Better just do not use HTTPS here.

 

2) You may have provided wrong path for the website root folder.

The test script will be created at that "...\xampp\htdocs\blog" folder (e.g. file named "script-name.php") and will be accessed via "http://127.0.0.1/script-name.php" -- are you sure it's correct folder for that URL?

Another possible scenario: you have some URL rewrite in place and it does not allow accessing that test script directly.

1

Please sign in to leave a comment.