Can't activate by account, due to the proxy problem.


I use the student account download the pycharm and want to activate the account. 

But it always mention me my host may be behind a proxy even when I don't use any proxy. 


I am glad I came back after a year. Thanks for Vincent Archambault 1, this solution works for me too. Yet I don't know why this workaround is still needed.


After working from home for so long, when I returned to the office my PyCharm licence "expired"  I ran into this issue - HOWEVER - there was no way to enter the program to change the proxy settings.

Thankfully the default proxy is the same as Fiddler (  I opened Fiddler, ensured "Capture HTTPS" was on and "Decrypt HTTPS" was off.  Worked!  Phew (after banging my head for an hour though). 

This should be fixed - at the very least allow a change to proxy settings in the license dialog.


The solution from Matthew Weber1 was correct and helped me, because I needet to insert a certificate in the cacerts of the JRE from PyCharm. The following screenshots show you how to find the folder with the JRE of PyCharm - if you had installed it with the gread JetBrains-Toolbox.



I went here first to find solutions. The Developer said there's something in the network that must be resolved. Tried the suggestions but the host's file in my C drive doesn't have JetBrains URL.

The problem in my case was the laptop's WiFi, network profile. It should be a Private network profile to login Educational JetBrains' account successfully. This method worked for me. Kindly check the screenshots here.

*Under the name of your WiFi, click 'Properties'.

*Check the Network Profile, it must be 'Private'.

*Done. Check if you can log in to your JB account to the Jetbrains IDE.


How do I resolve this in mac? I'm having the same problem. Cannot activate it by using my student ID


Please sign in to leave a comment.