2018.1.6: Updated to rvm ruby 2.6.2 - cannot install debug gems debase or ruby-debug-ide

Answered

Fails with message:

Error running 'Program': Failed to Install Gems. Following gems were not installed: /Applications/RubyMine.app/Contents/rb/gems/ruby-debug-ide-0.7.0.beta4.gem: While executing gem ... (OptionParser::InvalidOption) invalid option: --no-rdoc /Applications/RubyMine.app/Contents/rb/gems/debase-0.2.2.gem: While executing gem ... (OptionParser::InvalidOption) invalid option: --no-rdoc

Gems are Installed at: /Users/myuser/.rvm/gems/ruby-2.6.2

$ gem list

*** LOCAL GEMS ***

 

actioncable (5.1.7, 5.1.6.2)

actionmailer (5.1.7, 5.1.6.2)

actionpack (5.1.7, 5.1.6.2)

actionview (5.1.7, 5.1.6.2)

active_shipping (2.1.1)

active_utils (3.3.16)

activejob (5.1.7, 5.1.6.2)

activemerchant (1.93.0, 1.90.0)

activemodel (5.1.7, 5.1.6.2)

activerecord (5.1.7, 5.1.6.2)

activesupport (5.1.7, 5.1.6.2)

acts_as_list (0.9.19, 0.9.17)

addressable (2.6.0)

airbrussh (1.3.1)

akami (1.3.1)

archive-zip (0.7.0)

arel (8.0.0)

ast (2.4.0)

autoprefixer-rails (7.2.6)

awesome_nested_set (3.1.4)

aws-eventstream (1.0.3)

aws-sdk (2.10.134)

aws-sdk-core (2.10.134)

aws-sdk-resources (2.10.134)

aws-sigv4 (1.1.0, 1.0.3)

babel-source (5.8.35)

babel-transpiler (0.7.0)

bcrypt (3.1.12)

bigdecimal (default: 1.4.1)

bindex (0.7.0, 0.5.0)

binding_of_caller (0.8.0)

bootstrap (4.1.3)

browser-timezone-rails (1.0.3, 1.0.2)

builder (3.2.3)

bullet (6.0.0, 5.9.0)

bundler (2.0.1, default: 1.17.2)

bundler-unload (1.0.2)

byebug (11.0.1, 10.0.2)

cancancan (2.3.0)

canonical-rails (0.2.5, 0.2.4)

capistrano (3.11.0)

capistrano-bundler (1.5.0, 1.4.0)

capistrano-env_config (0.0.5)

capistrano-rails (1.4.0)

capistrano-rvm (0.1.2)

capistrano-yarn (2.0.2)

capistrano3-puma (3.1.1)

capybara (2.18.0)

carmen (1.1.1)

childprocess (1.0.1, 0.9.0)

chromedriver-helper (1.0.0)

chronic (0.10.2)

climate_control (0.2.0)

cliver (0.3.2)

cmath (default: 1.0.0)

codecov (0.1.14)

coderay (1.1.2)

coffee-rails (4.2.2)

coffee-script (2.4.1)

coffee-script-source (1.12.2)

concurrent-ruby (1.1.5)

connection_pool (2.2.2)

cookiejar (0.3.3)

crack (0.4.3)

crass (1.0.4)

csv (default: 3.0.4)

database_cleaner (1.7.0)

date (default: 2.0.0)

dbm (default: 1.0.0)

debase (0.2.3.beta5, 0.2.2)

debase-ruby_core_source (0.10.4)

debug_inspector (0.0.3)

devise (4.6.2, 4.6.1)

devise-encryptable (0.2.0)

did_you_mean (1.3.0)

diff-lcs (1.3)

discard (1.0.0)

docile (1.3.1)

domain_name (0.5.20180417)

dotenv (2.7.2, 2.5.0)

e2mmap (default: 0.1.0)

easypost (3.0.1)

elasticsearch (7.0.0, 6.1.0)

elasticsearch-api (7.0.0, 6.1.0)

elasticsearch-transport (7.0.0, 6.1.0)

em-http-request (1.1.5)

em-socksify (0.3.2)

envkey (1.1.0)

erubi (1.8.0)

erubis (2.7.0)

et-orbi (1.2.1, 1.1.6)

etc (default: 1.0.1)

ethon (0.12.0)

eventmachine (1.2.7)

excon (0.64.0, 0.62.0)

execjs (2.7.0)

executable-hooks (1.6.0)

factory_bot (4.10.0)

factory_bot_rails (4.10.0)

faker (1.9.3, 1.9.1)

faraday (0.15.4)

faraday_middleware (0.12.2)

faraday_middleware-aws-sigv4 (0.2.4)

fcntl (default: 1.0.0)

ffi (1.9.24)

fiddle (default: 1.0.0)

fileutils (default: 1.1.0)

flipper (0.16.2, 0.16.0)

flipper-active_record (0.16.2, 0.16.0)

flipper-ui (0.16.2, 0.16.0)

fog-aws (2.0.1)

fog-core (1.45.0)

fog-json (1.2.0)

fog-xml (0.1.3)

font-awesome-rails (4.7.0.5, 4.7.0.4)

formatador (0.2.5)

forwardable (default: 1.2.0)

friendly_id (5.2.5)

fugit (1.2.0, 1.1.6)

fuzzy-string-match (1.0.1)

gdbm (default: 2.0.0)

gem-wrappers (1.4.0)

globalid (0.4.2)

guard (2.15.0)

guard-compat (1.2.1)

guard-rspec (4.7.3)

gyoku (1.3.1)

handlebars_assets (0.23.3, 0.23.2)

hashdiff (0.3.9, 0.3.8)

hashie (3.6.0, 3.5.7)

htmlentities (4.3.4)

http (4.1.1, 4.0.0)

http-cookie (1.0.3)

http-form_data (2.1.1)

http_parser.rb (0.6.0)

httpi (2.4.4)

i18n (1.6.0)

io-console (default: 0.4.7)

io-like (0.3.0)

ipaddr (default: 1.2.2)

ipaddress (0.8.3)

irb (default: 1.0.0)

jaro_winkler (1.5.2)

jbuilder (2.8.0)

jmespath (1.4.0)

jquery-rails (4.3.3)

js_cookie_rails (2.2.0)

json (2.2.0, default: 2.1.0)

jstz-rails3-plus (1.0.5)

jwt (2.1.0)

kaminari (1.1.1)

kaminari-actionview (1.1.1)

kaminari-activerecord (1.1.1)

kaminari-core (1.1.1)

listen (3.1.5)

logger (default: 1.3.0)

loofah (2.2.3)

lumberjack (1.0.13)

mail (2.7.1)

matrix (default: 0.1.0)

measured (2.4.0)

method_source (0.9.2)

mime-types (3.2.2)

mime-types-data (3.2019.0331, 3.2018.0812)

mimemagic (0.3.3)

mini_magick (4.9.3, 4.9.2)

mini_mime (1.0.1)

mini_portile2 (2.4.0)

minitest (5.11.3)

monetize (1.9.1)

money (6.13.3, 6.13.2)

multi_json (1.13.1)

multi_xml (0.6.0)

multipart-post (2.0.0)

mutex_m (default: 0.1.0)

nenv (0.3.0)

net-scp (2.0.0, 1.2.1)

net-ssh (5.2.0, 5.0.2)

net-telnet (0.2.0)

netrc (0.11.0)

nio4r (2.3.1)

nokogiri (1.10.3, 1.10.2, 1.10.1)

nori (2.6.0)

notiffany (0.1.1)

oa-core (0.3.2)

oauth (0.5.4)

oj (3.7.12, 3.7.4)

omniauth (1.9.0, 1.8.1)

omniauth-amazon (1.0.1)

omniauth-facebook (5.0.0)

omniauth-github (1.3.0)

omniauth-google-oauth2 (0.6.1, 0.5.3)

omniauth-oauth (1.1.0)

omniauth-oauth2 (1.5.0)

omniauth-twitter (1.4.0)

openssl (default: 2.1.2)

orm_adapter (0.5.0)

ostruct (default: 0.1.0)

paper_trail (9.2.0)

paper_trail-association_tracking (1.1.1, 1.0.0)

paperclip (5.3.0)

parallel (1.17.0, 1.16.2, 1.14.0)

paranoia (2.4.2, 2.4.1)

parser (2.6.3.0, 2.6.2.0, 2.6.0.0)

pg (0.21.0)

phonelib (0.6.33, 0.6.27)

poltergeist (1.18.1)

polyamorous (1.3.3)

polyglot (0.3.5)

popper_js (1.14.5)

power_assert (1.1.3)

powerpack (0.1.2)

prime (default: 0.1.0)

pry (0.12.2)

pry-byebug (3.7.0, 3.6.0)

pry-rails (0.3.9, 0.3.7)

pry-stack_explorer (0.4.9.3)

psych (default: 3.1.0)

public_suffix (3.0.3)

puma (3.12.1, 3.12.0)

raabro (1.1.6)

rack (2.0.7, 2.0.6)

rack-cache (1.9.0, 1.8.0)

rack-protection (2.0.5, 2.0.4)

rack-slashenforce (0.0.3)

rack-test (1.1.0)

rails (5.1.7, 5.1.6.2)

rails-assets-Cookies (1.2.3)

rails-assets-jstzdetect (1.0.6)

rails-controller-testing (1.0.4, 1.0.3)

rails-dom-testing (2.0.3)

rails-html-sanitizer (1.0.4)

railties (5.1.7, 5.1.6.2)

rainbow (3.0.0)

rake (12.3.2)

ransack (1.8.10, 1.8.8)

rb-fsevent (0.10.3)

rb-inotify (0.10.0)

rdoc (default: 6.1.0)

redcarpet (3.4.0)

redis (4.1.0, 4.0.3)

redis-actionpack (5.0.2)

redis-activesupport (5.0.7)

redis-namespace (1.6.0)

redis-rack (2.0.5)

redis-rack-cache (2.0.2)

redis-rails (5.0.2)

redis-store (1.6.0)

request_store (1.4.1)

responders (2.4.1)

rest-client (2.0.2)

rexml (default: 3.1.9)

rollbar (2.19.3, 2.18.0)

rspec (3.8.0)

rspec-core (3.8.0)

rspec-expectations (3.8.3, 3.8.2)

rspec-its (1.3.0, 1.2.0)

rspec-mocks (3.8.0)

rspec-rails (3.8.2, 3.8.1)

rspec-support (3.8.0)

rspec_junit_formatter (0.4.1)

rss (default: 0.2.7)

rubocop (0.68.1, 0.66.0, 0.65.0)

rubocop-rspec (1.32.0, 1.30.1)

ruby-debug-ide (0.6.1)

ruby-progressbar (1.10.0)

ruby_dep (1.5.0)

rubygems-bundler (1.4.5)

RubyInline (3.12.4)

rubyzip (1.2.2)

rvm (1.11.3.9)

safe_yaml (1.0.5)

sass (3.7.4, 3.7.3)

sass-listen (4.0.0)

sass-rails (5.0.7)

savon (2.12.0)

scanf (default: 1.0.0)

sdbm (default: 1.0.0)

searchkick (4.0.0, 3.1.2)

selenium-webdriver (3.142.0, 3.141.0)

shell (default: 0.7)

shellany (0.0.1)

shoulda-matchers (3.1.3)

sidekiq (5.2.7, 5.2.3)

sidekiq-cron (1.1.0, 1.0.4)

simple_oauth (0.3.1)

simplecov (0.16.1)

simplecov-html (0.10.2)

skylight (3.1.5, 3.1.2)

skylight-core (3.1.5, 3.1.2)

socksify (1.7.1)

solidus (2.6.0)

solidus_api (2.6.0)

solidus_auth_devise (2.1.0)

solidus_backend (2.6.0)

solidus_core (2.6.0)

solidus_frontend (2.6.0)

solidus_prototypes (1.0.0)

solidus_sample (2.6.0)

solidus_support (0.2.2)

spring (2.0.2)

spring-commands-rspec (1.0.4)

spring-watcher-listen (2.0.1)

sprockets (3.7.2)

sprockets-es6 (0.9.2)

sprockets-rails (3.2.1)

sshkit (1.18.2, 1.18.0)

state_machines (0.5.0)

state_machines-activemodel (0.6.0, 0.5.1)

state_machines-activerecord (0.6.0, 0.5.2)

stringio (default: 0.0.2)

strscan (default: 1.0.0)

sync (default: 0.5.0)

terrapin (0.6.0)

test-unit (3.2.9)

thor (0.20.3)

thread_safe (0.3.6)

thwait (default: 0.1.0)

tilt (2.0.9)

timecop (0.9.1)

tinymce-rails (4.2.8)

tracer (default: 0.1.0)

truncate_html (0.9.3)

turbolinks (5.2.0)

turbolinks-source (5.2.0)

typhoeus (1.3.1)

tzinfo (1.2.5)

uglifier (4.1.20)

unf (0.1.4)

unf_ext (0.0.7.6, 0.0.7.5)

unicode-display_width (1.5.0, 1.4.1)

uniform_notifier (1.12.1)

url (0.3.2)

vcr (4.0.0)

warden (1.2.8)

wasabi (3.5.0)

web-console (3.7.0)

webmock (3.5.1)

webrick (default: 1.4.2)

websocket-driver (0.6.5)

websocket-extensions (0.1.3)

xmlrpc (0.3.0)

xpath (3.2.0)

yelp (2.1.5)

ZenTest (4.11.2)

zlib (default: 1.0.0)

 

 

1 comment

Hello,

that appears to be a known issue: https://youtrack.jetbrains.com/issue/RUBY-23317

Could you please check how it goes in RubyMine 2019.1.1 or 2018.3.5?

0

Please sign in to leave a comment.