Problem with my Complete Current Statement

Hey guys, I'm sorry to post this here because I'm sure this is a small problem originated from my stupidity, but I need some help :(

I don't know what I've done, but my Complete Current Statement (default Ctrl + Shift + Enter on Ubuntu) is not wraping the variable when I use it to complete a method name.

The expected behaviour is this, but what I'm getting is the following: for instance, I want the size of an array $test, if I start typing sizeof right before the variable and then hit ctrl + shift + enter, this is what happens:

sizeof($var);$test

Have I messed up another configuration option? I know this is a small thing, but its driving me mad and I can't seem to find anything about this.

3 comments
Comment actions Permalink

Hi there,

Please show how what your code completion popup shows you just before you hit Ctrl+Shift+Enter. Some screencast is even better.

I'm on Windows and it works fine here:

$test = 123;
size[CARET]$test;

produces

sizeof($test)[CARET];
  • Maybe it's cased by some plugin? try disabling all non-default plugins.
  • What the context (plain PHP file or something else)? Try in brand new project.
  • Maybe it's some custom Live Template entry or stuff like that (screenshot should help here).

Backup and delete your IDE config (while IDE is closed) and see if it will work with default settings.

0
Comment actions Permalink

Thanks for your help :)

 This is whats happening in a newly created project:

I've tried to disable all of the non-default plugins and Live Templates but still got the same outcome :/

 

These are my Keymap settings (the only command mapped to Ctrl+Shift+Enter is this one):

I just couldn't find where are my config files. Where do they get stored? Is there a way to do this inside the IDE?

0
Comment actions Permalink

https://intellij-support.jetbrains.com/hc/en-us/articles/206544519-Directories-used-by-the-IDE-to-store-settings-caches-plugins-and-logs

NOTE: If you are using "IDE Settings Sync" or "Settings Repository" plugins then such settings work a bit differently, but still, deleting them should work (or disable those plugins and restart IDE so IDE uses only local settings).

P.S. Material UI Theme is known to cause different kinds of issues in seemingly unrelated areas, so disable that plugin as well when testing.

0

Please sign in to leave a comment.