Hitting breakpoint causes exit

Answered

I recently upgraded to 2019 community version.

Now when I set and hit a breakpoint, my program exits.  It briefly shows the variables and stuff like it has hit the breakpoint.  Then after 1 second, the program exits printing this on the console:


Process finished with exit code -1073741819 (0xC0000005)

Even a super-simple program has this problem:


for i in range(30):
print(i)

I LOVE PYCHARM!!! Help!!!
10 comments

I uploaded the files in the log folder.  There was also a folder in there labeled:

threadDumps-freeze-20190505-154216-PC-191.6605.12

That has a number of text files in it.  Do I need to upload these files too?

I uploaded:

idea.log, idea.log1, idea.log2, idea.log3

The last program I ran was this:

a = 0
b = 1
c = 2

I set a breakpoint on b=1.  The name of the program was scratch_263.py.

It crashed as it always does.

0

Thanks for the logs. It seems you're using at least one custom plugin - try to disable it. 

Also, try to create a new project and new interpreter - does the issue still reproduce? If it does, please collect all the files and dumps from the log folder in the archive and upload it to the FTP.

0

We're getting somewhere!

I made a new env and used a different interpreter.  It turned out to be the interpreter.

When I went back to my original project and switched from 3.6 to 3.7 then it works.

BTW, my version of 3.6 was installed as part of Conda, something I don't actively use.  I wonder if part of your upgrade had an issue with it.

Here's a screenshot of my project's interpreter's choices.

0

Ok, the issue might be caused by PyCharm's Cython debugger extensions. Let's try disabling them. Please add the following environment variables to your run/debug configuration:

PYDEVD_USE_CYTHON=NO
PYDEVD_USE_FRAME_EVAL=NO

And try again.

0

OK, I did that.  My environment variables line in the screenshot above now has those 2 extra variables on them.  I still crash out after hitting a breakpoint.  Sorry.  I switched to 3.7 on the same setup screen and then it broke with no problem.  Back to 3.6 and once again it exits upon breakpoint.

 

0

Hi Mike, could you please disable Settings | Build, Execution, Deployment | Python Debugger | PyQt compatible option? Has it helped to resolve the crash?

1

That fixed it!!!!

It works!

For some projects I'm using pyside2.  Will this be a problem by turning this off?

OH THANK YOU for fixing this!!!

I can debug again!

 

0

Glad it has helped!

>For some projects I'm using pyside2. Will this be a problem by turning this off?

Try to set PyQt compatible explicitly to PySide2 instead of default Auto.

0

Setting it to PySide2 caused the problem to return.

 

0

Please sign in to leave a comment.