cannot fetch remote documentation: internal server error for Django on clicking on ctrl + q

Answered

This happens when I use the shourcut ctr+q. How to fix it? I tried to reinstall pycharm

8 comments

Hi, could you please invalidate caches with File | Invalidate Caches & Restart? Has it helped to resolve the problem?

0

I see, could you please attach idea.log file from Help | Show Log in ... to the ticket https://youtrack.jetbrains.com/issue/PY-26574?

0

I added the file. Its name is idea1.log. Did you add the idea.log file - because I did not uploaded it.?

0

The same error in PyCharm for OSX.

PyCharm 2019.1.1 (Professional Edition)
Build #PY-191.6605.12, built on April 3, 2019
JRE: 11.0.2+9-b159.34 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.4

0

Thank you for the log, I created a separate ticket https://youtrack.jetbrains.com/issue/PY-35907 as it seems to be a different problem.

0

I'm also getting this error in 2019.1.1:

2019-07-03 16:40:27,320 [ 21345] INFO - mentation.DocumentationManager -
java.lang.NullPointerException
at com.jetbrains.django.codeInsight.DjangoDocumentationLinkProvider.getExternalDocumentationUrl(DjangoDocumentationLinkProvider.java:157)
at com.jetbrains.python.documentation.PythonDocumentationProvider.getOnlyUrlFor(PythonDocumentationProvider.java:569)
at com.jetbrains.python.documentation.PythonDocumentationProvider.getUrlFor(PythonDocumentationProvider.java:545)
at com.intellij.lang.documentation.CompositeDocumentationProvider.getUrlFor(CompositeDocumentationProvider.java:124)
at com.intellij.codeInsight.documentation.DocumentationManager$MyCollector.lambda$getDocumentation$1(DocumentationManager.java:1132)
at com.intellij.openapi.application.impl.ApplicationImpl.runReadAction(ApplicationImpl.java:974)
at com.intellij.openapi.application.ReadAction.compute(ReadAction.java:57)
at com.intellij.codeInsight.documentation.DocumentationManager$MyCollector.getDocumentation(DocumentationManager.java:1128)
at com.intellij.codeInsight.documentation.DocumentationManager.lambda$doFetchDocInfo$12(DocumentationManager.java:782)
at com.intellij.util.concurrency.QueueProcessor.runSafely(QueueProcessor.java:232)
at com.intellij.util.Alarm$Request.runSafely(Alarm.java:368)
at com.intellij.util.Alarm$Request.run(Alarm.java:355)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
at com.intellij.util.concurrency.SchedulingWrapper$MyScheduledFutureTask.run(SchedulingWrapper.java:224)
at com.intellij.util.concurrency.BoundedTaskExecutor.doRun(BoundedTaskExecutor.java:220)
at com.intellij.util.concurrency.BoundedTaskExecutor.access$100(BoundedTaskExecutor.java:26)
at com.intellij.util.concurrency.BoundedTaskExecutor$2.lambda$run$0(BoundedTaskExecutor.java:198)
at com.intellij.util.ConcurrencyUtil.runUnderThreadName(ConcurrencyUtil.java:224)
at com.intellij.util.concurrency.BoundedTaskExecutor$2.run(BoundedTaskExecutor.java:194)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.base/java.lang.Thread.run(Unknown Source)

0

@Pokemaster103

Please update to the latest (https://www.jetbrains.com/pycharm/download) and try again.

0

Please sign in to leave a comment.