Configure Python Interpreter and No R interpreter defined

Answered

Every time I open pycharm it says:

1. Configure Python Interpreter in the top right part of the page

2. No R interpreter defined at the bottom of the page.

How Do I fix these two issues ?

Thanks.

5 comments
Comment actions Permalink

Hi,

  • Python interpreter can be configured in Settings | Project ... | Project Interpreter
  • R interpreter in Settings | Languages & Frameworks | R Language

If you don't need R support - uninstall or disable the corresponding plugin in Settings | Plugins.

0
Comment actions Permalink
  • uninstalled R language support so thanks for that.
  • It looks like my python interpreter is already configured but still whenever I open up pycharm, it requires me to configure it every time:
0
Comment actions Permalink

How do you start PyCharm? By the screenshot it looks like you used a command line launcher to open a specific Python file, this is a suboptimal workflow as PyCharm creates a temporary project for this file, so any project customization like setting an interpreter is gone once you restart the IDE.

It is better to either open the directory containing the file as a project in PyCharm or create a new project and open the specific file in it with File | Open. Another way is to add a file parent directory as a Content Root to a new project with Settings | Project ... | Project Structure, this way you will see it in the project tree.

0
Comment actions Permalink

I have not used a command line launcher to open a python file because I don't know how to do that.

What do you mean by directory containing a file ?

I also went to the place you directed me too and where is the project tree ?

0
Comment actions Permalink

>I have not used a command line launcher to open a python file

Could you please specify how exactly did you start PyCharm and open Position_predictor.py?

>What do you mean by directory containing a file ?

I mean C:\Users\Sepehr Vali\Desktop\Research\code\

0

Please sign in to leave a comment.