IRB console not accepting commands

Answered

I'm using RubyMine 2019.1.1 on Ubuntu 2018.04, and I can run rails console just fine from the terminal (Even the terminal inside RubyMine). But when I open an IRB tool window inside Rubymine, it never accepts any command and keeps chaining what I typy every time I hit the Enter key:

It first loads up with a very long line (notice the soft-wrap icons):

 

I then typed Pathname and hit Enter. Nothing happened:

 

Next, I typed ActiveRecord, and hit Enter. It appears Pathname and ActiveRecord are concatenated but I'm still stuck on the first line of the console ([1] pry(main)>):

Please help!

3 comments

Hello,

could you please specify whether you manage to Run rails server in RubyMine via corresponding Run configuration? Does it show the correct output? Does IRB console works in case of plain Ruby projects?

0

Hi. Thanks for touching base with me. And yes, I can run Rails Server within RubyMine just fine. I also tried to run IRB Console on a different project and it also worked. Looks like it's to this one project that can't run IRB Console properly within RubyMine 2019 specifically (RubyMine 2016 works just fine).

So there's something about this project that breaks IRB Console in RM 2019 specifically. If you swap the project, or run the console via a terminal (either native Ubuntu Terminal or RM 2019's own terminal), or downgrade to RM 2016, it works.

I suspect that it's one of the gems that we use that somehow only affects the newest version of RM. I wonder if anyone else has run into the same issue and knows how to fix it. Will do some investigation on my own and report back if I find a fix or a workaround.

 

Thank you very much!

 

 

 

0

Thank you! It'd be also great if you could share this project so that we can check it as well (it's possible to submit an issue on our tracker and attach code with restricted access). 

0

Please sign in to leave a comment.