100% cpu on webstorm

I am running my react app and the processor gets to 100% cpu when I run the work project. At work, the pc I have has a weaker processor and it never jumps that much, still. My i7-8565U has 90-100% cpu. WHAT IS THIS IN THE NAME OF GOD? It's getting frustrating because I really don't want to start using Visual Studio Code

My work station has 12 GB ram and a processor with 2 threads

I have 16GB ram and a processor with 4 threads. 

What is happening?

5 comments
Comment actions Permalink

does it happen on running or on debugging? also, what process is using the CPU - java or node.js?

0
Comment actions Permalink

I have the same problem.
Currently opened 3 windows with webstorm projects. There are no currently indexing running or applications in the terminal. Just idling.
The process is called node. 

0
Comment actions Permalink

it must be one of language services started from the IDE, most probably Typescript language service

It's just a wrapper around the tsserver provided by Microsoft, there is not much we can do to fix its CPU usage; you can turn it off in  Settings | Languages & Frameworks | TypeScript

0
Comment actions Permalink

Same problem here. Whenever It's indexing, the fan gets too loud and my laptop becomes too hot. I use MacBook Pro (Catalina). Happens almost everytime. It's really annoying so now I have switched to VSCode though I love to use webstorm. I hope there's some alternative to fix it.

0
Comment actions Permalink

@Ameet    Indexing is indeed very resource-intensive and might utilize all your CPU cores. But it is normally only performed on project opening/switching VCS branches (and on massive changes made to project folders - for example, on generating files, that's why we strongly recommend to exclude build destination directories from project)

If you face issue with constant project re-indexing while editing your code, this is likely a bug that has to be fixed; please report it to support by submitting either a support ticket or a bug in youtrack

0

Please sign in to leave a comment.