No tab auto-indenting from the start of a line.

Answered

Pycharm does not recognize the previous line's block level when tabbing from the start of a line. If I press 'enter' when the cursor is on the end of line 3 it will correctly indent twice or more, however if I am inserting code from the start of a blank line(4) and press 'tab' it only indent once rather than two or more times. This is Sublime and PyDev's default behavior. Does Pycharm have this feature?  

 

1:class A(): 
2:    def __init__(self): 
3:        print 1 
4:

5 comments
Comment actions Permalink

Hi,

There is no such feature at the moment.

Please feel free to submit a feature request about it to our issue tracker using the link https://youtrack.jetbrains.com/issues/IDEA

0
Comment actions Permalink

I have installed Pycharm 2019 and the smart indent after control statements (for, if, etc) after I press ENTER does not occur. How can I enable it back again?

0
Comment actions Permalink

This must be code style settings.

Please go to [File | Settings | Editor | Code Style | Python] and restore the default settings, it should help.

0
Comment actions Permalink

It does not work that way. Can it be because I installed Pycharm 2019 with Ubuntu Software Center? In my previous Pycharm 2018 this feature worked just fine.

0
Comment actions Permalink

Very strange. Please try re-installing from the official site: 

[Download PyCharm](https://www.jetbrains.com/pycharm/download/)

0

Please sign in to leave a comment.