4 comments
Comment actions Permalink

Try creating new blade file with a random name (e.g. qwerty.blade.php) and check if the syntax is correct there.

Also please update to 2017.2.7.

0
Comment actions Permalink
I installed latest version :
PhpStorm 2019.1.2
Build #PS-191.7141.52, built on May 8, 2019
Licensed to PhpStorm Evaluator
Expiration date: June 26, 2019
and imported all settings from prior versions.


and syntaX is not highlited at all : https://imgur.com/a/eIAvFxa
I run menu utem with all page selected
Code->Reformat Code
It did not help.
Can it be some additive options/plugings?
0
Comment actions Permalink

Looking at your screenshot, I could see a directive that is not in the default list: @setup

You may want to add custom directives in "Languages & Frameworks | PHP | Blade > Directives" menu window.

What is about the other part of the code, it seems to be that Envoy syntax is not a 100% the same as Blade, so it is not highlighted. You may check that Blade highlighting is working in general for this file by adding some known directives (like @if or @php).

 

Also, you may submit a feature request for the Envoy files support:

https://youtrack.jetbrains.com/newIssue

0
Comment actions Permalink

Blade syntax is supported ok for all my blade.php files.

Whos works with envoy? Do you use phpstorm or some other editors?

0

Please sign in to leave a comment.