Problem developing a plugin for idea ultimate and webstorm - build expired

Answered

Hi,

We have a plugin that assists in java development.
We were developing it using the gradle build for a while now, using intellij community edition as a sandbox.

Lately we added some features for javascript development, meaning we had to move to developing against an idea ultimate sandbox, because the community edition does not include the javascirpt plugin.

Now, we can successfully run and debug (using `gradle runIde`). But when we try to run `gradle buildPlugin` it fails with the following error

> Task :buildSearchableOptions FAILED
This build of IntelliJ IDEA has expired. Please download a new build from http://eap.jetbrains.com/idea2019

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':buildSearchableOptions'.
> Process 'command '/home/amir/.gradle/caches/modules-2/files-2.1/com.jetbrains/jbre/jbrx-8u202-linux-x64-b1483.39/jre/bin/java'' finished with non-zero exit value 7

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 2s
9 actionable tasks: 5 executed, 4 up-to-date

Anybody encountered this and can offer a solution/workaround?

Thanks
Amir

4 comments
Comment actions Permalink

Just, if anyone is having this too, the solution was to change to the latest version - IU-2019.1.2

2
Comment actions Permalink

Are you using an EAP version as target IDE? Please update to the latest EAP version then.

0
Comment actions Permalink

Thank you Yann, for the quick response.

We are not using an EAP build.

When we developed only for java, we had 

intellij {
version 'IC-2019.1'
}

in our build script.

 

Now that we develop for javascript, we changed it to 

intellij {
version 'IU-2019.1'
plugins 'JavaScriptLanguage'
}

This works fine for development, `gradle runIde` works like a charm.
However, doing `gradle buildPlugin` results in the above error.

 

Any advice?

Amir

 

0
Comment actions Permalink

Did you install/manage a license for the IntelliJ Ultimate sandbox? Anyway FTR there were a couple of problems with "buildSearchableOptions" in intellij-gradle plugin, make sure to always upgrade to the latest release https://github.com/JetBrains/gradle-intellij-plugin/issues?utf8=%E2%9C%93&q=is%3Aissue+buildSearchableOptions

0

Please sign in to leave a comment.