Managed Jupyter Server fails to start in PyCharm 2019.1

How can I make the managed Jupyter server work in PyCharm 2019.1 on (macOS High Sierra 10.13.6)?

 

I just upgraded to 2019.1 to check out the new Jupyter support.

The support document stats, that I had to: "Execute any of the code cells to launch the Jupyter server.". (See: https://www.jetbrains.com/help/pycharm/jupyter-notebook-support.html)

However, the managed server does not start, when executing a code cell. Instead I receive the following error message:

"Run Error: Jupyter package is not Installed!"

The package is installed, of course. A reinstall did not help. The only solution I found for now is to manually start a Jupyter notebook and set the appropriate URL with token in PyCharm's Jupyter server configuration.

 

Cheers, G

6 comments

Hi, 

Are you sure the jupyter package is installed for your main project interpreter? Have you tried installing the package by using the link provided by the error message?

If this doesn't help, please try to create a new project, create a new virtualenv project interpreter, create a new .ipynb file - the message should appear saying jupyter is not installed. Then install it using the same button. Does it work?

0

Thanks for the quick reply!

In my case the error message looked like this: 

And, well I do not know what the problem about the package installation was, but the configuration interface shows it was installed:

 

Creating a new project etc. did not help when I checked the box to inherit global site-packages. BUT:

What helped is NOT to inherit the global site-packages.

Then I received: 

 

And could easily install the package and the managed Jupyter server does fine.

 

So I got it. Thanks for your help!

0

Hi everyone, 

I tried the instructions here. I installed Jupyter as well, but I still cannot open Jupyter from Pycharm. It shows an empty run error. Please guide on how to start Jupyter from Pycharm.

0

@Naseer Faheem

Please post what Jupyter log say when you execute your cell. You can find it in the Jupyter tab.

0

Hi Andrey, 

Please see the attached screen shot for the Jupyter Log. I can copy the URL and run it from the browser, but I think that's counter intuitive since Jupyter notebook is already doing that. 

Note: I used to be able to run Jupyter form my Pycharm 2018 Professional. Our company upgraded to the 2019.1, and all of a sudden we are facing this issue. 

 

Thanks, 

0

@Naseer Faheem

According to your screenshot, Jupyter server is starting without issue, so it should work. Ensure that you have preview pane enabled, the buttons for that should be in the top-right corner.

Another suggestion would be to update to PyCharm 2019.2 if you haven't already.

0

Please sign in to leave a comment.