Cannot find IDEA 2019.2 EAP release that can be downloaded by gradle

Answered

IntelliJ IDEA 2019.2 EAP has been released some days ago.  So I wanted to upgrade/adapt my plugin which is incompatible to this release.  But I cannot find any 192 release in this list: https://www.jetbrains.com/intellij-repository/releases

Is this list not complete?

Is it possible to use the latest EAP releases in a gradle project?

6 comments
Comment actions Permalink

I just tried to upgrade my build to use the 2019.2 EAP, and many of the JPS classes appear to not be available now. The following classes are missing:

import org.jetbrains.jps.ModuleChunk;
import org.jetbrains.jps.builders.DirtyFilesHolder;
import org.jetbrains.jps.builders.FileProcessor;
import org.jetbrains.jps.builders.java.JavaSourceRootDescriptor;
import org.jetbrains.jps.builders.storage.SourceToOutputMapping;
import org.jetbrains.jps.incremental.*;
import org.jetbrains.jps.incremental.messages.BuildMessage;
import org.jetbrains.jps.incremental.messages.CompilerMessage;
import org.jetbrains.jps.incremental.messages.ProgressMessage;

However some are available, org.jetbrains.jps.model.* and .service.*. Have these classes been broken out into a separate artifact?

0
Comment actions Permalink

Colin, could you please file a bug with more details about your setup, Thanks.

0
Comment actions Permalink

Sure - would you like that in the gradle-intellij-plugin, or in YouTrack? If YT, against which project?

0

Please sign in to leave a comment.