Process finished with exit code 7 then after bundle install Process finished exit code 5

Answered

I'm really having a hard time getting my RubyMine to debug properly. I just tried again and this is what I am getting:

D:\RailsInstaller\Ruby2.3.3\bin\ruby.exe D:\RailsInstaller\Ruby2.3.3\lib\ruby\gems\2.3.0\gems\ruby-debug-ide-0.7.0.beta7\bin\rdebug-ide --key-value --disable-int-handler --evaluation-timeout 10 --evaluation-control --time-limit 100 --memory-limit 0 --rubymine-protocol-extensions --port 49955 --host 0.0.0.0 --dispatcher-port 49956 -- C:/Users/kac56/RubymineProjects/untitled1/bin/rails server -b 127.0.0.1 -p 3000 -e development
Fast Debugger (ruby-debug-ide 0.7.0.beta7, debase 0.2.3.beta5, file filtering is supported) listens on 0.0.0.0:49955
Could not find gem 'turbolinks (~> 5) x86-mingw32' in any of the gem sources listed in your Gemfile.
Run `bundle install` to install missing gems.

Process finished with exit code 7

So I tried installing the missing gems and this error appeared:

D:\RailsInstaller\Ruby2.3.3\bin\ruby.exe C:\Users\kac56\RubymineProjects\untitled1\bin\bundle install
Fetching gem metadata from https://rubygems.org/.............
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies....
Using rake 12.3.2
Using concurrent-ruby 1.1.5
Using i18n 1.6.0
Using minitest 5.11.3
Using thread_safe 0.3.6
Using tzinfo 1.2.5
Fetching activesupport 5.1.7
Installing activesupport 5.1.7
Using builder 3.2.3
Using erubi 1.8.0
Using mini_portile2 2.4.0
Using nokogiri 1.10.3 (x86-mingw32)
Using rails-dom-testing 2.0.3
Using crass 1.0.4
Using loofah 2.2.3
Using rails-html-sanitizer 1.0.4
Fetching actionview 5.1.7
Installing actionview 5.1.7
Using rack 2.0.7
Using rack-test 1.1.0
Fetching actionpack 5.1.7
Installing actionpack 5.1.7
Using nio4r 2.3.1
Using websocket-extensions 0.1.4
Using websocket-driver 0.6.5
Fetching actioncable 5.1.7
Installing actioncable 5.1.7
Using globalid 0.4.2
Fetching activejob 5.1.7
Installing activejob 5.1.7
Using mini_mime 1.0.1
Using mail 2.7.1
Fetching actionmailer 5.1.7
Installing actionmailer 5.1.7
Fetching activemodel 5.1.7
Installing activemodel 5.1.7
Using arel 8.0.0
Fetching activerecord 5.1.7
Installing activerecord 5.1.7
Using public_suffix 3.1.0
Using addressable 2.6.0
Using bindex 0.7.0
Using bundler 1.17.3
Using byebug 11.0.1
Fetching xpath 3.2.0
Installing xpath 3.2.0
Fetching capybara 2.18.0
Installing capybara 2.18.0
Using childprocess 1.0.1
Using coffee-script-source 1.12.2
Using execjs 2.7.0
Using coffee-script 2.4.1
Using method_source 0.9.2
Using thor 0.20.3
Fetching railties 5.1.7
Installing railties 5.1.7
Using coffee-rails 4.2.2
Using ffi 1.11.1 (x86-mingw32)
Fetching jbuilder 2.9.1
Installing jbuilder 2.9.1
Using puma 3.12.1
Using sprockets 3.7.2
Using sprockets-rails 3.2.1
Fetching rails 5.1.7
Installing rails 5.1.7
Using rb-fsevent 0.10.3
Using rb-inotify 0.10.0
Using rubyzip 1.2.3
Using sass-listen 4.0.0
Using sass 3.7.4
Using tilt 2.0.9
Using sass-rails 5.0.7
Fetching selenium-webdriver 3.142.3
Installing selenium-webdriver 3.142.3
Fetching sqlite3 1.4.1
Installing sqlite3 1.4.1 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory:
D:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/sqlite3-1.4.1/ext/sqlite3
D:/RailsInstaller/Ruby2.3.3/bin/ruby.exe -I
D:/RailsInstaller/Ruby2.3.3/lib/ruby/site_ruby/2.3.0 -r
./siteconf20190611-12372-nty7f3.rb extconf.rb
checking for sqlite3.h... no
sqlite3.h is missing. Install SQLite3 from http://www.sqlite.org/ first.
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers. Check the mkmf.log file for more details. You may
need configuration options.

Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=D:/RailsInstaller/Ruby2.3.3/bin/$(RUBY_BASE_NAME)
--with-sqlcipher
--without-sqlcipher
--with-sqlite3-config
--without-sqlite3-config
--with-pkg-config
--without-pkg-config
--with-sqlcipher
--without-sqlcipher
--with-sqlite3-dir
--without-sqlite3-dir
--with-sqlite3-include
--without-sqlite3-include=${sqlite3-dir}/include
--with-sqlite3-lib
--without-sqlite3-lib=${sqlite3-dir}/lib

To see why this extension failed to compile, please check the mkmf.log which can
be found here:

D:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/extensions/x86-mingw32/2.3.0/sqlite3-1.4.1/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in
D:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/sqlite3-1.4.1 for
inspection.
Results logged to
D:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/extensions/x86-mingw32/2.3.0/sqlite3-1.4.1/gem_make.out

An error occurred while installing sqlite3 (1.4.1), and Bundler cannot
continue.
Make sure that `gem install sqlite3 -v '1.4.1' --source 'https://rubygems.org/'`
succeeds before bundling.

In Gemfile:
sqlite3

Process finished with exit code 5

I've made sure that my Ruby and Rails are both up to date and I'm still getting errors. Any help or guidance would be much appreciated.

Any ideas what this might mean?

1 comment
Comment actions Permalink

Hello Kate,

according to the error message there're problems with sqlite3 gem installation, please check the following thread with a similar issue:

https://github.com/sparklemotion/sqlite3-ruby/issues/82

0

Please sign in to leave a comment.