Don't auto-open files after copy-paste



Is there by chance a setting that turns off auto-opening files after they have been copied? I sometimes need to copy quite a bit of large minified files. Filesize + auto softwrap make opening the files slow. I have to wait for them to open & manually close them again every time. It's a small annoyance but if there is a setting that i missed i'd love to know.

Thanks for your time!


When you say copying files, I assume you mean via the "copy" refactoring [Refactor > Copy (F5)]. If so, there is an "Open copy in editor" option in the bottom right corner you can unselect. (Last used setting will be retained for next use.) If you are not seeing this option above the OK/Cancel buttons, use your mouse to increase the dialog box's height.

If you are you are not using the Copy refactoring, try using it for copying of files (although a conventional Ctrl+C and Ctrl+V in the project window triggers the Copy Refactoring). Or otherwise provide more detail on the steps you are doing so someone can assist you. Hope this helps.


I can't believe i missed that! Copied so many files (both methods) that i automatically click "OK" on the prompt. Thanks that really helps!


Thanks, I missed that too. I am sure that this was the default behaviour before, but out of the blue, it suddenly seemed to work differently.

It was annoying to edit the wrong file because I often thought I would edit the copied file when the original file was still open actually.

So now I'm happy to know the solution :-)


Please sign in to leave a comment.