org.jetbrains.intellij version 0.4.9 not found by gradle

Answered

Going step by step through the plugin tutorial. Noticed that my latest-everything (plugins, IDE) ultimate version does not create a java source folder as depicted  in the tutorial. That is OK but it makes me wonder if  the issue I encountered is related to it somehow.

Being careful to check the IntelliJ Platform Plugin as specified here:

https://www.jetbrains.org/intellij/sdk/docs/tutorials/build_system/prerequisites.html

I create the required class and groupID section of the action of plugin.xml. Here is what happens:

 

My Gradle tool window never populates with anything at all. It stays completely blank.

When I press revolving arrows icon in the Gradle tool window I get an error that explains that org.jetbrains.intellij "was not found at any of the following sources."

 

When I look at the SDK / configuration  for the project this makes sense since I don't see any way the jars containing those classes were included. I thought maybe I need to use the Intellij IDEA-IU-191.7479.19 as the SDK to make everything work but when I do that, it never finds it anyways and it tells me JAVA_HOME (or something) is not pointing to java. 

 

I am using Gradle 5.4.1 from sourced via sdkman. Gradle config screen seems to tell me it's OK.

 

Can't get past this.Any help greatly appreciated.

 

17 comments
Comment actions Permalink

Please post your build.gradle and attach all output/error messages in detail

1
Comment actions Permalink

Gradle file:

plugins {
id 'java'
id 'org.jetbrains.intellij' version '0.4.9'
}

group 'myGID'
version 'mySnapshot'

sourceCompatibility = 1.8

repositories {
mavenCentral()
}

dependencies {
testCompile group: 'junit', name: 'junit', version: '4.12'
}

// See https://github.com/JetBrains/gradle-intellij-plugin/
intellij {
version '2019.1.3'
}
patchPluginXml {
changeNotes """
Add change notes here.<br>
<em>most HTML tags may be used</em>"""
}

 

 

New information. On a machine connected to the internet, at some point in reproducing  this problem, I am sorry I can't remember where but it's the first few steps of the example, a popup appeared which said something about Gradle 4.9  and asking me a "do you want to " type question which I affirmed without really reading or thinking about it. After I agreed, it appeared to me that Ij went out on the internet and downloaded something, possibly gradle 4.9. Thereafter, the part of the issue where nothing appeared in the Gradle tool resolved itself.

 

The thing is, I have a Gradle installation that ij appears to not be complaining about. It is in sdkman. IJ will complain if  I select the wrong folder within  sdkman's Gradle install, which I did in fact do at some point.

I tell you this so you know that ij is not just mistakenly confirming any old folder as the home for Gradle; the Gradle setup panel in ij appears to know what it wants  and also appears to be happy with the sdkman install if I select the correct folder.

 

After that part of the  problem fixed itself (after the popup and download), I tried to reverse the fix in order to understand what the issue actually is. I don't know if it was because my machine was offline or it does't like Gradle 5.4 or it doesn't like Gradle 5.4 being where it is or what the issue is. It should not have had to go fetch another Gradle from the internet as I understand how things are supposed to work.

I was unsuccessful in my attempt to reverse the fix.

I tried to uninstall ij and reinstall, but it didn't work- it was still fixed.

Then I tried to manually do a seek-and-destroy  whatever config files ij creates so it would "forget" whatever it is it had done but I could not succeed doing that either.

Finally I literally reinstalled the OS and ij and everything else.

Then I went through the tutorial again,  this time disconnected from the internet.

I saw no popup and have the issues I originally had when I posted this yesterday.

It's hard for me to know what ij is doing wrt to Gradle  because I can't get a hold of the changing variables which are producing the effect.

I don't know where ij "puts" or "reads" Gradle to or from.

I actually don't even know if ij ships with Gradle or not- maybe I don't need to download it.

Honestly I don't know Gradle, and was hoping to dodge that bullet forever , but it looks like ij plugin writing is going to be intimately tied to Gradle so Gradle In Action made it to this weekend's reading list...lol....

 

It seems as if if the dev machine is not online, then the popup  never appears and therefore  the Gradle thing never straightens itself out. I don't get anything that says "you nee to download this Gradle thing for stuff to work". Maybe I am just supposed to know that.

The symptoms  suggest that 5.4 is no good for this purpose and 4.9 is necessary (that can't be true can it? ). Also that to work with Gradle builds, you have to be online (that can't be right either)

 

It's great and amazing  that ij can, on its own, figure out  something is wrong and configure your machine without input or knowledge from me but the downside of that is I don't know and can't learn what's going on, so I can't fix it.

 

That's really all I know.   Pushing that refresh icon on Gradle seems like it HAS TO go online each and every time you want to build (?) or nothing's going to work. I am just guessing. I don't understand any of this.

 

 

0
Comment actions Permalink

Gradle needs to be installed locally, it will be downloaded automatically if necessary. Please see help topics here https://www.jetbrains.com/help/idea/gradle.html.

0
Comment actions Permalink

Thanks for the info. The issue stands as it was however. Local installation of Gradle with 5.4 via sdkman on a computer  without access to the internet reliably  yields the results I described above.

0
Comment actions Permalink

The issue is reliably reproducible following the steps I described above which are 

1 install  OS,

2 install Java SDK,

3 install Gradle

4 set up Gradle and SDK such that IJ OKs both installations

5 follow tutorial

6 fail.

 

I can open a bug report if that's the right thing to do. I am just trying to get at if it's the correct thing to do or there is some other issue anyone recognizes.

 

Its possible no one at JB is aware that this sequence of events can happen because all JB's devs computers are connected to the internet so the issue never surfaces. But I don't know if it's that or something else.

0
Comment actions Permalink

What is your setting in Preferences | Build, Execution, Deployment | Build Tools | Gradle "Use Gradle From"? does it point to your Gradle 5.4 path?

0
Comment actions Permalink

IJ reports no issues with this directory. It WILL  report issues if I point to some other directory within this one like bin or something., From this I conclude that IJ  recognizes this folder as THE folder it wants.

0
Comment actions Permalink

this snippet:

plugins {
  // ...
  id 'org.jetbrains.intellij' version '0.4.9'
}

instructs a Gradle to download the plugin from https://plugins.gradle.org
It will not work without the network access

0
Comment actions Permalink

Thank you. Removing that line doesn't change anything for me.

 

Still nothing is Gradle tool window.

Still no java folder being created.

Still no compilation

0
Comment actions Permalink

adding screen shots of relevant files in next 2 posts

0
Comment actions Permalink

also the java folder you see was created by me and not the wizard, but reading the instructions, I am pretty sure the wizard should have created it .

0
Comment actions Permalink

Unfortunately, removing the plugin definition will not help. The plugin is required to handle sections of the build.gradle related to IntelliJ Plugin and to setup proper dependencies (e.g. on idea sources)

You need to have internet connection (at least for the first run).

src/main/java folder is not created automatically, indeed. This is expected behavior and outdated instructions. Thank you for reporting!

0
Comment actions Permalink

I see.

Yann and Nikita thank you both very much for your valuable attention !!

0
Comment actions Permalink

You are welcome. Please do not hesitate to ask further questions!

0
Comment actions Permalink

Hello all. I experienced identical symptoms even while connected to the internet. I'm using Windows 10 64-bit operating system, x64 processor. After some effort, I was able to get around this issue with the following steps:

 

* Open a terminal window with administrator privileges

* Navigate to your project's root directory

* Execute `gradle -d clean build`

 

Note: my gradle build initially locked up when trying to unzip a large archive that was downloaded. This was due to Windows Defender hogging my disk with an automatic scan (thanks Microsoft). If this issue arises, disable Windows Defender's automatic scanning and execute the gradle build again.

0

Please sign in to leave a comment.