TypeError: this.cliEngine is not a constructor

Hi!

When I try to set up eslint in webstorm using this guide https://www.jetbrains.com/help/webstorm/eslint.html i get an error message on each js file saying ESLint: TypeError: this.cliEngine is not a constructor . I have search the web and cannot find any way to fix this issue, does anyone know how to solve this problem?

Thanks,
Magnus

17 comments
Comment actions Permalink

Upon upgrading to 2019.1.3 the error no longer occurs so please consider this issue as solved.

Magnus

0
Comment actions Permalink

Hi!

I got the same problem with RubyMine and there are no 2019.1.3 patch with fix.

Please help me to find solution.

Kind regards,

Evgenii.

0
Comment actions Permalink

Until RubyMine 2019.1.3 is available, the only solution is downgrading ESLint

0
Comment actions Permalink

To add to what Elena said above, the issue is with ESLint version 6.  If you cannot upgrade IntelliJ, you'll need to downgrade to ESLint version 5.  

npm install --save-dev eslint@5

did the trick for me.

5
Comment actions Permalink

How about PhpStorm?

0
Comment actions Permalink

isn't PhpStorm 2019.1.3 available? You can download it from https://www.jetbrains.com/phpstorm/download/other.html, if upgrading directly to 2019.2 is not an option for you

0
Comment actions Permalink

You're right, I was on 2018 (:

0
Comment actions Permalink

the same error now with me

 

 

0
Comment actions Permalink

Please make sure to upgrade to the most recent IDE version

0
Comment actions Permalink

I have upgraded to 2019.2.2 and still facing this issue

0
Comment actions Permalink

Works fine for me in 2019.2.2

Please can you share a sample project the issue can be reproduced with?

0
Comment actions Permalink

It seems while upgrading, 2 versions of webstorm got installed. I was still using the old version. 
It is working in the new one. Apologies for the trouble

0
Comment actions Permalink

works fine for me in a new React app (create-react-app version: 3.1.2). Are you sure you are using 2019.2.2? Please provide a screenshot of Settings | Languages & Frameworks | JavaScript | Code Quality Tools | ESLint page and idea.log

0
Comment actions Permalink

It is not working with ESLint 8.0.1 but it works with 7.32.0

0
Comment actions Permalink

Ok then, is just that I clicked "Check for updates" before commenting, maybe it will be available for me later.

0

Please sign in to leave a comment.