CLion crash on startup on macOS Catalina


I wanted to upgrade to the Beta version of macOS 10.15 Catalina to test new c++ features. However, all jetbrain products, including CLion, have stopped working since the upgrade. 

The products start up and crash with a Java Runtime Error.

Here is the full error log. 


also in home folder a file (name similiar to java_error_in_studio_1645.log or java_error_in_idea_6992.log) is created (using android studio and idea respectively)




Yes, can confirm that these reports have been created for me as well.



It appears to be an issue with the JetBrains Runtime (based on OpenJDK 1.8) on MacOS Catalina Developer Preview 3, as I had no crashes on DP1 or DP2. It crashes during certain AWT calls.

I used a workaround to tell IntelliJ to run under the Oracle JDK 1.8 rather than the JetBrains Runtime, as explained in:

It's been running under the Oracle JDK for over an hour at the time of writing, and it hasn't crashed on me yet. It will urge you to switch to the JetBrains Runtime instead (which you normally should use), but that message can be ignored.


^ thank you very much for the tip, I was downloading an older version of the OS then I saw your post.




I had trouble getting the java8 installed with the oracle installer. If you have similar problems install the java8 version using homebrew and the adoptopenjdk/openjdk/adoptopenjdk8 cask. 

This fixed the problem for now, and I guess jetbrains will fix their runtime in the future


UPDATE: fixes path

To get all this working with homebrew, I did the following:

- brew tap AdoptOpenJDK/openjdk

- brew cask install adoptopenjdk8 #(this step install the JDK in /Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk)

- echo "/Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk" > ~/Library/Preferences/IntelliJIdea2019.1/idea.jvm #(or change to your specific app / version)

Now you can start IDEA with Adopt OpenJDK 8. Seems to be stable. There are warnings, for example when using font ligatures, but they can be worked around.



@Jan Paul Stegeman thanks for listing how tos. I think your last step is missing the file name, you just specified the folder name.

But it can be done inside IDE:

Double Shift > Switch IDE Boot JDK > Select /Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk

It seems stable, for now. 

Webstorm 2019.1


Copying the file after installing with brew as Jan Paul Stegeman suggested didn't work for me. Instead, I changed the settings as Cihad Turhan mentioned.


PyCharm was crashing when I tried opening a project, so in the Welcome to PyCharm Project screen, I accessed the settings with CMD+, and searched "JDK", from there, I was able to create a keyboard shortcut to prompt the menu that edits the JDK that PyCharm uses.


Jan Paul Stegman showed how to do it for the IntelliJ Idea IDE. Every IDE has its own settings file, probably you mistyped the name, therefore it is more secure to do it from the IDE directly to prevent typos. 


Using adopt open jdk indeed fixes the problem of not being able to load projects.

However, at least for me the editor has become much slower and freezes forever when trying to navigate through a project's files via the sidebar.

WebStorm has become unusable with the latest macOS Beta update.


I’ve not had any problems using CLion on the beta 3, but it is a beta for a reason. To further fix issues we need to file bug reports and wait for an answer from jetbrains dev


for me, using stock jdk is not without problems. (i tried openjdk8, openjdk12, openjdk13) and other than a few coloring/ui glitches, the bigest problem is I was unable to open some of the windows. e.g. open new project from file menu, or open layout inspector from within android studio.


I'll probably need to install an older version in my portable hard drive after all



For me the crash seems to happen when doing intellisense. If I turn on Power Save mode it doesnt crash.


Hi everyone!

It might be Feel free to comment or upvote in order to get updates. There is a workaround described in the issue, you can try using it.

@Vahid, please also see


Hi everyone,

I recently updated to macOS Catalina public beta 2. I get this error when I try to open a project in android studio. I'm not able to use android studio. Any fix for this?


Getting this error:

Crashed Thread: 25 Java: AWT-EventQueue-0

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000




I experienced this with the latest Catalina Beta and with Android Studio.

I solved it by going 'Help' -> 'Edit Custom VM Options' -> Add this as a new line: 

The problem of IDE crash under the beta system has been bothering me for a long time, my system environment: macOS 10.15 beta3.
IDEA, PyCharm, CLion, and DataGrip are all crash, including the EAP version and the JBR11 version.
Also tried a lot of solutions, for example:
  • Install adoptopenjdk8, turn on the power saving mode, useless (can enter the program, but runs extremely slowly)

Until I saw the answer from @Carlos Parker on this page, I was inspired and thanked him.
  • Visit:

  • Download the latest version of the adapter system

    • For example jbrsdk-8u212-osx-x64-b1591.1.tar.gz

    • unzip

      • You can use the command: sudo tar -C /Library/Java/JavaVirtualMachines/ -xvf jbrsdk-8u212-osx-x64-b1596.tar.gz

      • Or manually: unzip to /Library/Java/JavaVirtualMachines/jbrsdk-8u212 or a custom folder

    • Specify the IDE's JDK, for example IDEA2019.2 version

      • You can use the command: echo /Library/Java/JavaVirtualMachines/jdk > ~/Library/Preferences/IntelliJIdea2019.2/idea.jdk

      • Or manual operation:

        • Go to the directory: ~/Library/Preferences/IntelliJIdea2019.2

        • Create idea.jdk

        • Enter the directory of jdk above

        • save

    • Modify the IDE's VM parameters and add -Dsun.font.layoutengine=icu

      • It should be noted here that if it is manually installed, modify the vm parameter in the bin.

      • If it is installed with ToolBox, click the gear icon right of the installed program, select Settings, Edit to modify

    • problem solved.

Any questions, you can email me:


Temporary Fix:

Just install Early Access Programs for all the versions like Pycharm EAP, CLion EAP. This will help you. This is just a temporary fix from my side. Hope you enjoy.


Hello everyone!

As I've already written, there is a related issue in our tracker - Which is already fixed. This JBR8 build and this JBR11 build contain the fix. You can use it in an IDE via switcher.


Hey folks,

after analyzing this error a bit because it also happened to my Jetbrains Toolbox and Google Chrome I realized that it actually has nothing to do with JDK whatsoever.

This error occurs if you have invalid fonts in you "Font Book" app aka. the ~/Library/Fonts folder.

You might have a while ago imported fonts without a "name" key which will result in this "key cannot be nil" error now.

To fix it simply rename the fonts folder to sth. like ~/Library/Fonts.bak and then start "Font Book" app and reimport the fonts from the ~/Library/Fonts.bak folder.

But this time don't import fonts with warnings. Leave them in your ~/Library/Fonts.bak folder and wait until this bug is possibly fixed by some root cause...


Please sign in to leave a comment.