Marketplace Plugins are not loaded


Hello, I'm working for a company and I currently have access to but inside IntelliJ, when I browse the Marketplace, it says:

Marketplace Plugins are not loaded
Check the internet connection and try again

How can I configure it to be able to browse and download?

Thank you


Make sure the same proxy server is configured in the IDE as in your web browser.


The Auto-detect proxy settings worked. Thank you Serge


Hi, I'm having this issue as well - no plugins are loaded, check the internet connection

I enabled auto-proxy and tested for connection but that doesn't fix the issue




Any idea what I should do?

I'm using ultimate intellij version 2019.2.2 build 192.6603.28





Please add the following in Help | Debug Log Settings:

Reproduce the issue, check the logs for the more detailed errors: .

Upload the logs per and provide the file name so that we can review them.

Make sure you DON'T have -Djsse.enableSNIExtension=false added in Help | Edit Custom VM Options.


Uploaded log file with the following name, thanks


2019-09-19 11:24:02,064 [344393717] DEBUG - ntellij.util.proxy.CommonProxy - called for socket://
2019-09-19 11:24:02,064 [344393717] DEBUG - ntellij.util.proxy.CommonProxy - returns custom proxy for socket://, [DIRECT]
2019-09-19 11:24:02,187 [344393840] INFO - .ide.plugins.PluginManagerMain - Main plugin repository is not available ('SSL error probably caused by disabled SNI'). Please check your network settings.

It looks like you have the old -Djsse.enableSNIExtension=false VM option present in the .vmoptions file: Please remove it.


This is now fixed for me after seeing

'remove -Djsse.enableSNIExtension=false under Help > Edit Custom VM Options' and a restart did the trick.



I have the same issue with PhpStorm 2019.3.2. In the proxy view, the "check connection" works. These are my VM Options:



Looks like i have same problem. I changed debug log settings and uploaded compressed logs ( 


Serge Baranov see it:




Michalpietryka The issue seems to be caused by the special character in your user name:

Caused by: java.nio.file.InvalidPathException: Illegal char <?> at index 14: C:\Users\Micha?\AppData\Local\JetBrains\Toolbox\apps\PhpStorm\ch-0\193.5662.63.plugins\extensions.xml

Try relocating the plug-ins folder via Help | Edit Custom VM Options, adjust the location in -Didea.plugins.path option so that it's outside of your user directory.

Masterix21 you may have an issue with the permissions, try to delete `/Users/luca/Library/Application Support/PhpStorm2019.3/` directory and then install the plug-ins again after restarting the IDE.


Serge Baranov Thank you, problem is now solved, but i did not have that issue in previouse version of PhpStorm. 


I'm using Mackup to keep synced my settings and plugins on all my Apple computers. 

I have seen the log and seem that the symlink created by Mackup causes the problem.

Can you confirm it? There is a solution?


It's recommended to use account sync instead of the third-party solutions for JetBrains products: .


Just updated pycharm from 2019.3 to 2019.3.2

And was facing the same problem. Checked logs, guessed the problem is caused because of the russian letters in path, did as it said in this comment and it did the trick.

But my question is... why is that a problem? I've never had such problems for more that 2 years of daily use of pyCharm and than all of a sudden it's a problem?


P.S. Comment actions -> permalink, "Copy" button is not working for me.


I'm getting an error trying to browse plugins in IDEA that prevents it from working.  Clicked the "Browse repositories..." button in IntelliJ IDEA 12.1.8 Build 129.1561 (Ultimate).  The error is:

List of plugins was not loaded: The element type "hr" must be terminated by the matching end-tag "</hr>"., Unexpected end of file from server

Will you please assist?  Thanks!



Thanks for the report, we are looking into this problem. Please note that IDE versions 14+ are not affected. Is there any chance you can upgrade to a more recent version?


Serge, Thanks for looking into the issue and getting back with me.  :-)

> IDE versions 14+ are not affected. Is there any chance you can upgrade to a more recent version?

The version I use [IDEA 12.1.8 Ultimate] uses a purchased license.  If the new version of Ultimate is covered by my standing paid-for license (is free), then I can upgrade.  However, if a newer version requires another purchase, then no, I cannot upgrade at this time - unless I use the Community Edition instead.


It's a paid upgrade, you will need to wait until the issue is resolved on the server side.


> you will need to wait until the issue is resolved on the server side

Thanks for the info Serge!


We've forced HTTPS for all our hosts and IntelliJ IDEA 12 still uses HTTP to access plug-ins, it doesn't support redirects to HTTPS, hence the problem.

As a workaround you need to edit IDEA_HOME\bin\ file and add the following line there (forcing IDE to use HTTPS to access plug-ins):

Restart IntelliJ IDEA and see if it helps.


> As a workaround [...] edit IDEA_HOME\bin\ file and add [...]

Different error now:

List of plugins was not loaded: PKIX path building failed: unable to find valid certification path to requested target, Unexpected end of file from server

(If that's due to the corporate firewall then I can try outside it later.)


Yes, if your proxy is using a self signed certificate, you will need to install it into the JDK that is used to run IntelliJ IDEA, see .

If it's not self signed, the JDK may be missing the root CA, so switching to a more recent JDK version may also help: (will need to use environment variables approach since the Choose Runtime plug-in will not work with your IDE version).


Exited IDEA.  Exported the topmost certificate using a browser and imported it using keytool from jdk1.8.0_241 per the community post instructions.  Verified that the owner and issuer are my company.  Started IDEA.  Still get the SunCertPathBuilderException error.  I'll try outside the corporate network tomorrow.


Double check it's the same JDK as used to run IntelliJ IDEA in Help | About.


> Double check it's the same JDK as used to run IntelliJ IDEA in Help | About

Wow, good catch!  Help About says JRE 1.7.0_10, *not* jdk1.8.0_241.  I need to import using the JRE 1.7.0 keytool then, right?


Yes, you need to import into the JDK keystore that is used to run the IDE or change the JDK used to run the IDE to the one which has the updated keystore.


Please sign in to leave a comment.