Ruby Plugin with Intellij Idea is not working

Answered

I spent an hour on this and I am just frustrated because I have work to do and I need an IDE that works for me, not one where I work for it. 

I tried to install the ruby debugger and got this error:

'OptionParser::InvalidOption'

I read on the forum to do this:

As --no-doc are deprecated you have to use --no-document instead. --no-rdoc is not a valid parameter and wouldn't work. This issue was in RubyMine 2018.1 but is happily fixed in 2018.5 if you are running into this problem upgrade your RubyMine installation.

So if you go here:

https://plugins.jetbrains.com/plugin/1293-ruby/versions

You'll notice there is no 2018.5. I tried installing the ones in 2019 and it gave me an error that my version of IDEA does not support the 2019 plugin. I try to go to 'Check for Updates'. It shows that automatic updates are configured. 

I click the Download button and it redirects me to this URL:

https://www.jetbrains.com/idea/download/previous.html?utm_source=product&utm_medium=link&utm_campaign=IU&utm_content=2018.3#version20183

It seems like I have to download another 600mb file just to use ruby debugger? Why can't it just do an automatic update? All I am trying to do is use this debugger. 

 

 

 

 

 

1 comment
Comment actions Permalink

Hello,

in case you don't want to upgrade RubyMine you can try installing another debase gem version manually:


gem install debase -v 0.2.3.beta4
0

Please sign in to leave a comment.