Force the display of a page when a "502 Bad Gateway : problem of file encoding" occurs ?

The problem which I have since two week, is that when I create a new php file, and I include some HTML, the inner server return me a 502 bad gateway.

The terminal of Firefox tell me this thing : "HTML encoding doesn't declare. Some caracters are out of US-ASCII".

But :
- The file is encoding in UTF-8 (I have verified in the document properties).

- The editor settings is set in UTF-8 (Checked),

- the HTML page is set in UTF-8 (with "<meta charset="UTF-8">"),

- The externals ressources of the project are set in UTF-8.

 

And when I test the project on my own distant server, the project is working perfectly.

 

So my question is : there is a way to block this error in PHPStorm ?

1 comment
Comment actions Permalink

Unfortunately, no, there's no way around it. It's a 'sporadic' issue that got severely worse in 2019.1:

https://youtrack.jetbrains.com/issue/WEB-31859

There is work being done to solve it, but no ETA yet.

0

Please sign in to leave a comment.