RubyMine Stuck Creating Ruby SDK WSL

Answered

When I try to create the SDK the loading bar comes up, and nothing happens. Then I can't interact with RubyMine at all and have to force quit.

It might be worth noting I mapped the WSL file system to a drive so I can read the files with RubyMine.

I do have linux running.


12 comments
Comment actions Permalink

Hello,

could you please specify RubyMine version you're using? Have you tried 2019.2 Beta1? In addition, is it the path to `which rvm`?

0
Comment actions Permalink

Hello,

I am using  RubyMine 2019.1.2 Build 191.7141.58.

`which rvm` returns `/usr/share/rvm/bin/rvm`

I have not tried a beta build yet, I'll do that next.

0
Comment actions Permalink

Having the exact same issue

0
Comment actions Permalink

Hello Simon, 

is it on the last 2019.2.2? Are you adding rvm based SDK? Which path are you choosing?

0
Comment actions Permalink

Same but with docker-compose. Stuck at "Creating Ruby SDK" that takes infinite time to complete.

Although I can instantly launch that docker-compose setup in my regular shell(outside of RubyMine).

2019.2.3

0
Comment actions Permalink

@Nikita,

this thread is about WSL SDK so the mechanisms differ from the ones used for docker-compose. Please check also how it goes in RubyMine 2019.3 EAP and after running `docker-compose up` in the terminal.

0
Comment actions Permalink

A couple of irritating things about this:
When I click the Plus sign, RubyMine starts looking for ruby.exe. The Cancel button doesn't stop it from doing this, so I'm waiting 30 secons for it to time out.

Then when I select The plus-sign, the menu appears, and I select New Remote, set it to WSL, Ubuntu, and add the path to `which rbenv`. Then it says 'Creating Ruby SDK' and is stuck there. Again, the Cancel button does not stop it from doing this, but it seems to never finish. I've waited several minutes...

RubyMine 2019.2.3 (192.6817.16)

UPDATE:

I installed the early access preview of RubyMine 2019.3 and WSL seems to work here.

0
Comment actions Permalink

@Henrik,

would it be possible to check also 2019.3 EAP? Does the problem persist there? Which Linux are you using?

0
Comment actions Permalink

Olga Kuvardina,

I already checked it with 2019.3 EAP and added it to the post above. It appears to be working fine here!

Linux distro is as mentioned Ubuntu.

The first annoyance that I mentioned is also present in the EAP.

Cheers

0
Comment actions Permalink

Do you mean that it still looks for ruby.exe without any possibility to cancel it? 

0
Comment actions Permalink

We fixed the issue with IDE hanging while WSL SDK is being added:

https://youtrack.jetbrains.com/issue/RUBY-25284

2019.3.2 Preview is going to be released this week so could you please check whether your issue persists (although it differs a bit)

0

Please sign in to leave a comment.