How to change credentianl.helper for vsc in intellij?

Answered

Hello! I need your help. The main problem is a little bit different. When I trying to fetch/pull/push via Intellij VSC, it requires to enter password. Despite I enter correct password, the process throws 'Authentication failed' error. I read in some post that Intellij uses command line git .  But I can fetch/pull/push via console without any authentication successfully. Then I looked through the VS Console and saw that it doesn't use any credential.helper, although git uses store. You can see it in images. How can I solve it?

1 comment
Comment actions Permalink

While IntelliJ indeed overrides credential helper to ensure authentication is handled on the IDE side (this is needed e.g. for the correct operation of GitHub integration), entering a valid password when promoted should work, and the password should be saved.

So the main issue here is 'Authentication failed' error after entering a password. Maybe you use 2fa on the server, and a token has to be used instead of a password? Also, there might be some related errors in the IDE logs. Please check, and submit an issue to https://youtrack.jetbrains.com/issues/IDEA if 

You may tell IDE to use helper as a workaround as well. See https://youtrack.jetbrains.com/issue/IDEA-177665#focus=streamItem-27-3423882.0-0

In 2019.1.4 and later versions, there will be an option on the login dialog and in the settings https://youtrack.jetbrains.com/issue/IDEA-211317

0

Please sign in to leave a comment.